.
.
.
.
.
.

Auftragsprogrammierung

Projektanfrage über Web Formular   per Online-Formular 
Projektanfrage über E-Mail  Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!
Projektanfrage per Telefon  +49 (0)151 / 164 55 914
Projektanfrage weitere Informationen  weitere Informationen 

Sie benötigen Hilfe oder Unterstützung? Nutzen Sie für Ihre Anfrage unser Online-Formular, senden Sie uns eine Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!  oder rufen Sie uns einfach an.

Für kurze Fragen und einfachere Problemlösungen bieten wir unseren Quick-Support an.

Referenzen

 Bosch 
  T-Systems
  Hagebau
  Siemens
 Areva  VW
 Haufe-Lexware  British American Tobacco
  nagel group farbe
 

Systemsteuerung aus Excel heraus aufrufen

In diesem Beitrag stellen wir Ihnen ein kleines Tool vor, mit dem die einzelnen Elemente der Windwos-Systemsteuerung per VBA aus Excel heraus aufgerufen werden können.

Der folgende Screenshot zeigt den Aufbau der Excel-Tabelle.



In Spalte A befindet sich die Beschreibung des jeweiligen Elements der Systemsteuerung, Spalte B enthält das Kommando zum Aufrufen des Elements der Systemsteuerung und in Spalte C können Erläuterungen eingetragen werden.

Das Tool besteht aus zwei Dateien:
  • Element 1 ist die Excel-Tabelle aus Abbildung 1.
  • Element 2 ist eine Batch-Datei, welche per VBA aufgerufen wird und welcher das entsprechende Kommando aus der Excel-Tabelle (Spalte B) übergeben wird.

Damit das Tool funktioniert, müssen Sie die Batch-Datei in das gleiche Verzeichnis kopieren, in der sich auch die Excel-Datei befindet.

Wenn Sei nun in Spalte B einen beliebigen Eintrag mit der Maus anklicken, wird das entsprechende Element der Systemsteuerung gestartet.

Über den nachfolgenden Link können Sie die beiden Dateien (Excel- und Batch-Datei) als Zip-File herunterladen.

Drucken E-Mail

Relevante Artikel

  • Leere Zeilen aus Excel Liste entfernen

    Leere Zeilen sind in Excel immer wieder ein showstopper. Um eine möglichst konsistente Datentabelle zu bekommen, sollten Leerzeilen in...

  • Verwendung der Gültigkeitsprüfung

    Die Gültigkeitsprüfung oder Datenüberprüfung ist ein Excel-Feature, durch das eine korrekte Daten-Eingabe in ein Arbeitsblatt sichergestellt wird....

  • Office 2013 Upload Center

    Mit Hilfe des Office Upload Centers behält der Anwender den Überblick über die in der Cloud gespeicherten Dateien. Office 2013 bietet die...

  • Fehlerwerte beim Drucken unterdrücken

    In Ihrer Excel-Datei befinden sich Fehler wie beispielsweise #DIV/0!, #WERT, #NV oder andere Fehlerwerte. Diese Fehlerwerte lassen sich für den...

  • Bezug der Summenformel soll erhalten bleiben

      207051     A B C 1 10 =SUMME(A1:A5) =SUMME(INDIREKT("A1"):INDIREKT("A5")) 2 10     3 10     4 10     5 10       Wird nach der Zeile 3 eine neue Zeile eingefügt, passiert folgendes:...

Projektanfrage

 Sie benötigen eine Auftragsprogrammierung?
 Oder suchen Unterstützung bei der 
 Lösungsfindung?

  Nutzen Sie unser Anfrageformular

  Jetzt anrufen unter 0151 / 164 55 914

 Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! Projektanfrage per Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! senden

  Weitere Informationen

sitepanel question2

P
R
O
J
E
K
T
A
N
F
R
A
G
E
Ihre Zufriedenheit ist unser Ziel, deshalb verwenden wir Cookies. Mit diesen ermöglichen wir, dass unsere Webseite zuverlässig und sicher läuft, wir die Performance im Blick behalten und Sie besser ansprechen können. Cookies werden benötigt, damit technisch alles funktioniert und Sie auch externe Inhalte lesen können. Des Weiteren sammeln wir unter anderem Daten über aufgerufene Seiten, getätigte Käufe oder geklickte Buttons, um so unser Angebot an Sie zu Verbessern. Mehr über unsere verwendeten Dienste erfahren Sie unter „Weitere Informationen“. Mit Klick auf „Akzeptieren“ erklären Sie sich mit der Verwendung dieser Dienste einverstanden. Ihre Einwilligung können Sie jederzeit mit Wirkung auf die Zukunft widerrufen oder ändern.