Systemsteuerung aus Excel heraus aufrufen

In diesem Beitrag stellen wir Ihnen ein kleines Tool vor, mit dem die einzelnen Elemente der Windwos-Systemsteuerung per VBA aus Excel heraus aufgerufen werden können.

Der folgende Screenshot zeigt den Aufbau der Excel-Tabelle.



In Spalte A befindet sich die Beschreibung des jeweiligen Elements der Systemsteuerung, Spalte B enthält das Kommando zum Aufrufen des Elements der Systemsteuerung und in Spalte C können Erläuterungen eingetragen werden.

Das Tool besteht aus zwei Dateien:
  • Element 1 ist die Excel-Tabelle aus Abbildung 1.
  • Element 2 ist eine Batch-Datei, welche per VBA aufgerufen wird und welcher das entsprechende Kommando aus der Excel-Tabelle (Spalte B) übergeben wird.

Damit das Tool funktioniert, müssen Sie die Batch-Datei in das gleiche Verzeichnis kopieren, in der sich auch die Excel-Datei befindet.

Wenn Sei nun in Spalte B einen beliebigen Eintrag mit der Maus anklicken, wird das entsprechende Element der Systemsteuerung gestartet.

Über den nachfolgenden Link können Sie die beiden Dateien (Excel- und Batch-Datei) als Zip-File herunterladen.

Partnerlinks

Relevante Artikel

  • Verweis mit Suchkriterien in mehreren Spalten

    Mit der Funktion =SVERWEIS() können nur Suchbegriffe in einer einzigen Spalte gesucht werden. Befinden sich die...

  • Druckbereich dynamisch ohne VBA festlegen

    Um nur einen Teilbereich z.B. einer großen Umsatzliste auszudrucken, bietet Excel den Befehl Datei / Druckbereich /...

  • Neue Diagrammtypen in Excel 2016

    Mit dem neuen Update zu Excel 2016 Preview wurden neue Diagramm-Typen zu Excel hinzugefügt. Folgende neuen Diagramme stehen zur...

  • Den vierten Wert aus einer Liste extrahieren

    Mit dem Befehl INDEX(Matrix;Zeile;Spalte) kann der Wert der angegebenen Zeile ermittelt werden.   A B 1 Haus Test 2 Tisch Werner 3 Bett Hans 4 Stuhl Excel 5 Blume Mai 6 Monitor Work 7 Tastatur Bild 8 Flasche Telefon 9     10 =INDEX(A1:B8;4;2)   In diesem Beispiel...

  • Zellinhalte verstecken

    Es kommt immer wieder vor, dass Zellinhalte versteckt werden sollen. Sei es, um Inhalte vor neugierigen Blicken zu...

Ihre Zufriedenheit ist unser Ziel, deshalb verwenden wir Cookies. Mit diesen ermöglichen wir, dass unsere Webseite zuverlässig und sicher läuft, wir die Performance im Blick behalten und Sie besser ansprechen können. Cookies werden benötigt, damit technisch alles funktioniert und Sie auch externe Inhalte lesen können. Des Weiteren sammeln wir unter anderem Daten über aufgerufene Seiten, getätigte Käufe oder geklickte Buttons, um so unser Angebot an Sie zu Verbessern. Mehr über unsere verwendeten Dienste erfahren Sie unter „Weitere Informationen“. Mit Klick auf „Akzeptieren“ erklären Sie sich mit der Verwendung dieser Dienste einverstanden. Ihre Einwilligung können Sie jederzeit mit Wirkung auf die Zukunft widerrufen oder ändern.