.
.
.
.
.
.

Auftragsprogrammierung

Projektanfrage über Web Formular   per Online-Formular 
Projektanfrage über E-Mail  Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!
Projektanfrage per Telefon  +49 (0)151 / 164 55 914
Projektanfrage weitere Informationen  weitere Informationen 

Sie benötigen Hilfe oder Unterstützung? Nutzen Sie für Ihre Anfrage unser Online-Formular, senden Sie uns eine Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!  oder rufen Sie uns einfach an.

Für kurze Fragen und einfachere Problemlösungen bieten wir unseren Quick-Support an.

Referenzen

 Bosch 
  T-Systems
  Hagebau
  Siemens
 Areva  VW
 Haufe-Lexware  British American Tobacco
  nagel group farbe
 

Nachgestelltes Minus nach Import korrigieren

207074



Nach einem Textimport werden die Vorzeichen von Zahlen nicht immer richtig dargestellt.
Oft wird das Minus-Zeichen hinter die Zahl gestellt. Mit solch einer Zahlendarstellung kann Excel
nicht umgehen und somit natürlich nicht weiterrechnen.

Mit einer Funktion lässt sich das Problem jedoch leicht lösen.
Das hinten angestellte Minus wird einfach abgeschnitten und vor die Zahl gesetzt.

Die Funktion dazu lautet:

=WENN(RECHTS(A3;1)="-";WERT("-"&LINKS(A3;LÄNGE(A3)-1));A3)

Das folgende Beispiel soll das ganze noch einmal verdeutlichen!
A B C
1 Zahlen vor Zahlen nach
2 Korrektur Korrektur
3

15,5

15,5 =WENN(RECHTS(A3;1)="-";WERT("-"&LINKS(A3;LÄNGE(A3)-1));A3)
4

13

13 =WENN(RECHTS(A4;1)="-";WERT("-"&LINKS(A4;LÄNGE(A4)-1));A4)
5 -12,3 -12,3 =WENN(RECHTS(A5;1)="-";WERT("-"&LINKS(A5;LÄNGE(A5)-1));A5)
6 23,56- -23,56 =WENN(RECHTS(A6;1)="-";WERT("-"&LINKS(A6;LÄNGE(A6)-1));A6)
7 17,5- -17,5 =WENN(RECHTS(A7;1)="-";WERT("-"&LINKS(A7;LÄNGE(A7)-1));A7)
8 -22 -22 =WENN(RECHTS(A8;1)="-";WERT("-"&LINKS(A8;LÄNGE(A8)-1));A8)
9 21- -21 =WENN(RECHTS(A9;1)="-";WERT("-"&LINKS(A9;LÄNGE(A9)-1));A9)
10

1,55

1,55 =WENN(RECHTS(A10;1)="-";WERT("-"&LINKS(A10;LÄNGE(A10)-1));A10)
11 55,55- -55,55 =WENN(RECHTS(A11;1)="-";WERT("-"&LINKS(A11;LÄNGE(A11)-1));A11)

Sie müssen nur die Formel in die Zelle C3 eintragen und mit dem Autoausfüllkästchen nach unten ziehen.


 

Drucken E-Mail

Relevante Artikel

  • Fortlaufende Reihen-Sequenzen ermitteln

    In diesem Beispiel zeigen wir Ihnen, wie sich eine sequenzielle Reihe erzeugen lässt. Als Ausgangliste dient eine Reihe mit verschiedenen Zahlen ab...

  • Office 2013 Upload Center

    Mit Hilfe des Office Upload Centers behält der Anwender den Überblick über die in der Cloud gespeicherten Dateien. Office 2013 bietet die...

  • Ermittlung Quartal und Quartalsende

    Wenn Sie das Quartal ermitteln möchten, indem sich das angegebene Datum befindet, dann verwenden Sie einfach diese Formel: =AUFRUNDEN(MONAT(A1)/3;0) Im Beispiel...

  • Zelländerungen überwachen

    Excel stelle eine Funktion zur Überwachung von Zellen zur Verfügung. Wenn Sie beispielsweise Berechnungen ausführen, die Änderungen in einem anderen...

  • Zahl mit gewählter Währung formatieren

    In diesem Beispiel zeigen wir Ihnen, wie Sie abhängig von der gewählten Währung beliebige Zellen in der gewählten Währung formatieren können. Das...

Projektanfrage

 Sie benötigen eine Auftragsprogrammierung?
 Oder suchen Unterstützung bei der 
 Lösungsfindung?

  Nutzen Sie unser Anfrageformular

  Jetzt anrufen unter 0151 / 164 55 914

 Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! Projektanfrage per Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! senden

  Weitere Informationen

sitepanel question2

P
R
O
J
E
K
T
A
N
F
R
A
G
E
Ihre Zufriedenheit ist unser Ziel, deshalb verwenden wir Cookies. Mit diesen ermöglichen wir, dass unsere Webseite zuverlässig und sicher läuft, wir die Performance im Blick behalten und Sie besser ansprechen können. Cookies werden benötigt, damit technisch alles funktioniert und Sie auch externe Inhalte lesen können. Des Weiteren sammeln wir unter anderem Daten über aufgerufene Seiten, getätigte Käufe oder geklickte Buttons, um so unser Angebot an Sie zu Verbessern. Mehr über unsere verwendeten Dienste erfahren Sie unter „Weitere Informationen“. Mit Klick auf „Akzeptieren“ erklären Sie sich mit der Verwendung dieser Dienste einverstanden. Ihre Einwilligung können Sie jederzeit mit Wirkung auf die Zukunft widerrufen oder ändern.