Auftragsprogrammierung

Projektanfrage über Web Formular   per Online-Formular 
Projektanfrage über E-Mail  Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!
Projektanfrage per Telefon  +49 (0)151 / 164 55 914
Projektanfrage weitere Informationen  weitere Informationen 

Sie benötigen Hilfe oder Unterstützung? Nutzen Sie für Ihre Anfrage unser Online-Formular, senden Sie uns eine Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!  oder rufen Sie uns einfach an.

Referenzen

 Bosch 
  T-Systems
  Hagebau
  Siemens
 Areva  VW
 Haufe-Lexware  British American Tobacco
  nagel group farbe

Verwendung der Gültigkeitsprüfung

Die Gültigkeitsprüfung oder Datenüberprüfung ist ein Excel-Feature, durch das eine korrekte Daten-Eingabe in ein Arbeitsblatt sichergestellt wird.

Es gibt verschiedene Möglichkeiten für die Einstellung der Gültigkeit einer Eingabe in eine Zelle, siehe Abbildung.

 

 

  1. Jeden Wert:

In die Zelle kann jeder beliebige Wert erfasst werden

  1. Ganze Zahl:

Hier können Sie die Unter- und Obergrenze der Ganzzahl definieren. Dezimalzahlen sind hier nicht zulässig

  1. Dezimal:

Ähnlich wie Ganze Zahl, nur dass hier Dezimalzahlen erfasst werden müssen

  1. Liste:

Bei Liste können Sie Gültigkeitslisten definieren. Sie erhalten nun ein Drop-Down-Feld, in dem Sie die Werte der Liste auswählen können

  1. Datum:

Bei Datum können Sie ein Anfangs- und ein Enddatum bestimmen. Anschließend kann in der Zelle nur noch ein Datum zwischen diesen beiden Terminen erfasst werden.

  1. Zeit:

Wie bei Datum können Sie hier eine Anfangs- und eine Endzeit erfassen.

  1. Textlänge

Bei Auswahl der Option Textlänge können Sie bestimmen wie lang der zu erfassende Text sein soll bzw. höchstens sein darf.

  1. Benutzerdefiniert:

Bei Benutzerdefiniert können Sie über eine Formel die Abfrage bestimmen

Auf die Punkte "4. Liste" und "8. Benutzerdefiniert" möchte ich etwas näher eingehen. Die anderen Optionen sind weitgehend selbsterklärend.


Erläuterungen zu Punkt 4. Liste:

Sie können eine Liste mit Gültigkeitskriterien auf dem gleichen Tabellenblatt erstellen und als Bereichsangabe übergeben. Es ist aber nicht ohne weiteres Möglich, eine Liste durch Selektion auf einem anderen Tabellenblatt auszuwählen. Möchten Sie jedoch eine Quell-Liste auf einem anderen Tabellenblatt oder gar einer anderen Arbeitsmappe erstellen so müssen Sie für diese Liste einfach nur einen Bereichsnamen vergeben.

Als Quell-Liste erfassen Sie nun ganz einfach diesen Namen. Haben Sie beispielsweise der Liste den Namen 'liste' gegeben, so erfassen Sie als Quelle einfach den Namen wie folgt: =liste

Jetzt verwendet Excel als Gültigkeitsliste die Quelle mit dem Namen liste und es ist vollkommen gleichgültig wo diese Liste steht, ob auf dem gleichen oder auf einem anderen Tabellenblatt. Ja es ist jetzt sogar egal, ob diese Liste gar in einer anderen Arbeitsmappe befindet. Steht die Quell-Liste jedoch in einer anderen Arbeitsmappe, so muss diese geöffnet sein, wenn die Gültigkeitsprüfung vorgenommen wird.

Erläuterungen zu Punkt 8. Benutzerdefiniert:

Über diesen Parameter können beliebige Formeln in der Datenüberprüfung verwendet werden. Beispielsweise lassen sich über die benutezerdefinierte Gültigkeitesprüfung Doppelerfassungen verhindern.

Gehen Sie dazu wie folgt vor:

  1. Starten Sie die Datenüberprüfung über das Menü Daten / Datentools / Datenüberprüfung --> Benutzerdefiniert
  2. Möchten Sie beispielsweise den Zellbereich A1:A100 Doppelerfassungen prüfen, dann geben Sie als Formel folgendes:  =ZÄHLENWENN(A:A;A1)=1
  3. Anschließend übertragen Sie die Gültigkeitskriterien durch Format-Übertrag auf die gewünschten Zellen in der Spalte A, z. B. A1 bis A100.
  4. Bei jeder Doppelerfassung im ausgewählten Bereich, hier Zelle A1 bis A100 wird nun ein Hinweis ausgegeben. Über die indiduelle Steuerung der Fehlermeldung können Sie auch einen individuellen Text hinterlegen.

Drucken E-Mail

Relevante Artikel

  • SUMMEWENN mit Textfragmenten

    Mit Hilfe der Funktion SUMMEWENN() werden in einem Bereich nur die Werte summiert, die mit dem Suchkriterium übereinstimmen. Mit =SUMMEWENN(A1:A50;">20";B1:B50")...

  • Excel 2010 - Das Backend

    In Excel Excel 2010 sind alle Optionen und die Einstellungsmöglichkeiten, welche sich auf das Programm beziehen im sogenannten Backend...

  • Gruppierungslinien in Listen einfügen

    Gruppierungslinien sorgen in umfangreichen Listen für mehr Übersicht. Im Beispiel liegt eine sortierte Liste mit Namen vor. Ziel ist, dass nach...

  • Listen mit Zahlen - Buchstaben Kombinationen korrekt sortieren

    Dieses Beispiel zeigt, wie sich Listen korrekt sortieren lassen die Zahlen und Zahlen-Buchstaben Kombinationen enthalten. Sehen Sie sich dazu...

  • Office 2013 Upload Center

    Mit Hilfe des Office Upload Centers behält der Anwender den Überblick über die in der Cloud gespeicherten Dateien. Office 2013 bietet die...

Projektanfrage

 Sie benötigen eine Auftragsprogrammierung?
 Oder suchen Unterstützung bei der 
 Lösungsfindung?

  Nutzen Sie unser Anfrageformular

  Jetzt anrufen unter 0151 / 164 55 914

 Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! Projektanfrage per Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! senden

  Weitere Informationen

sitepanel question2

P
R
O
J
E
K
T
A
N
F
R
A
G
E
Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Bestätigung erklären Sie sich mit der Verwendung von Cookies auf Excel-Inside Solutions einverstanden.
Weitere Informationen Ok