Auftragsprogrammierung

Projektanfrage über Web Formular   per Online-Formular 
Projektanfrage über E-Mail  Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!
Projektanfrage per Telefon  +49 (0)151 / 164 55 914
Projektanfrage weitere Informationen  weitere Informationen 

Sie benötigen Hilfe oder Unterstützung? Nutzen Sie für Ihre Anfrage unser Online-Formular, senden Sie uns eine Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!  oder rufen Sie uns einfach an.

Referenzen

 Bosch 
  T-Systems
  Hagebau
  Siemens
 Areva  VW
 Haufe-Lexware  British American Tobacco
  nagel group farbe

Wie oft ist ein bestimmtes Zeichen in einer Text- bzw. Zeichenfolge vorhanden

In diesem Beispiel zeigen wir Ihnen, wie sich die Anzahl der Zeichen ermitteln lässt, die in einem Textstring vorhanden ist.

Nehmen wir an, in Zelle B5 befindet sich ein Text, in dem die Anzahl eines bestimmten Zeichens gesucht werden soll.
Zelle B7 enthält das Such-Zeichen, nach welchem der Textstring aus Zelle B5 durchsucht wird und in Zelle B9 soll das Ergebnis, also die Anzahl der Zeichen angezeigt werden, die im Text gefunden wurde, siehe Abbildung 1.

Anzahl Zeichen im Textstring - 1
Abbildung 1

Um nun in Zelle B9 die Häufigkeit des Buchstabens "e" zu ermitteln erfassen Sie in Zelle B9 die folgende Formel:

=(LÄNGE(B5)-LÄNGE(WECHSELN(B5;B7;"")))/LÄNGE(B7)

Damit wird als Ergebnis entsprechend ermittelt, siehe Abbildung 2.

Anzahl Zeichen im Textstring - 2
Abbildung 2


Das Ergebnis lautet in diesem Fall 4. Der Buchstabe "e" befindet sich also 4 mal in dem Beispieltext.

Mit dieser Formel können Sie aber nicht nur einzelne Zeichen, sondern auch Zeichenfolgen und Ziffern bzw. Zahlen suchen und finden. Die nachfolgenden Beispiele geben einen kleinen Einblick in die Such-Möglichkeiten.

Beispiel 1: Der Textstring "nor" befindet sich 2 Mal in dem Text

Anzahl Zeichen im Textstring - 3

Beispiel 2: Die Ziffer 2 befindet sich 3 Mal im Text

Anzahl Zeichen im Textstring - 4

Beispiel 3: Die Zahl 22 befindet sich 1 Mal im Text

Anzahl Zeichen im Textstring - 5


Wie Sie sehen, können mit der aufgezeigten Formel ganz beliebige Suchbegriffe erstellt und der Textstring entsprechend damit durchsucht werden.

Drucken E-Mail

Relevante Artikel

  • Summierung über mehrere Tabellen

    Möchten Sie eine Summierung wie in Bild 1 über mehrere Tabellenblätter durchführen, dann gehen Sie wie folgt vor: A B C D E 1 1 2 2 3 3 4 4 5 5 6 7 15 Summe 8 9 10 11 Summen der Tabellenblätter Tabellenblätter 12 15 Summe Tabellenblatt 1 1 13 16 Summe Tabellenblatt 2 2 14 20 Summe Tabellenblatt 3 3 Bild 1: Summierung über mehrere...

  • Quartal und Halbjahr aus Datum ermitteln

    Dieser Beitrag zeigt, wie sich das Quartal und das Halbjahr mit Hilfe einer kleinen Formel aus einem Datum ableiten lassen. Im Beispiel befindet...

  • Führende Nullen in Zellen ermöglichen

    Da Excel bei der Eingabe von Zahlen mitdenkt, werden standardmäßig führende Nullen abgeschnitten. Bei der Eingabe von 01234567 wird in der Zelle nur...

  • Nachgestelltes Minus nach Import korrigieren

    207074 Nach einem Textimport werden die Vorzeichen von Zahlen nicht immer richtig dargestellt. Oft wird das Minus-Zeichen hinter die Zahl gestellt. Mit...

  • Bezug der Summenformel soll erhalten bleiben

      207051     A B C 1 10 =SUMME(A1:A5) =SUMME(INDIREKT("A1"):INDIREKT("A5")) 2 10     3 10     4 10     5 10       Wird nach der Zeile 3 eine neue Zeile eingefügt, passiert folgendes:...

Projektanfrage

 Sie benötigen eine Auftragsprogrammierung?
 Oder suchen Unterstützung bei der 
 Lösungsfindung?

  Nutzen Sie unser Anfrageformular

  Jetzt anrufen unter 0151 / 164 55 914

 Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! Projektanfrage per Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! senden

  Weitere Informationen

sitepanel question2

P
R
O
J
E
K
T
A
N
F
R
A
G
E
Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Bestätigung erklären Sie sich mit der Verwendung von Cookies auf Excel-Inside Solutions einverstanden.