.
.
.
.
.
.

Auftragsprogrammierung

Projektanfrage über Web Formular   per Online-Formular 
Projektanfrage über E-Mail  Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!
Projektanfrage per Telefon  +49 (0)151 / 164 55 914
Projektanfrage weitere Informationen  weitere Informationen 

Sie benötigen Hilfe oder Unterstützung? Nutzen Sie für Ihre Anfrage unser Online-Formular, senden Sie uns eine Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!  oder rufen Sie uns einfach an.

Für kurze Fragen und einfachere Problemlösungen bieten wir unseren Quick-Support an.

Referenzen

 Bosch 
  T-Systems
  Hagebau
  Siemens
 Areva  VW
 Haufe-Lexware  British American Tobacco
  nagel group farbe
 

Einfügen von Leerzeilen in eine fortlaufende Excel-Liste

In diesem Beispiel zeigen wir eine Möglichkeit, um formelbasiert Leerzeilen in eine fortlaufende Excel-List ein zufügen.
Dabei spielt es keine Rolle ob die Liste Zahlen oder Texte enthält.

Die folgende Abbildung zeigt die Ausgangstabelle mit einer Reihe von Bestellnummern.



Ziel ist es, in Spalte B eine Liste mit jeweils einer Leerzeile zwischen den einzelnen Bestellnummern zu erzeugen. 
Erfassen Sie dazu folgende Formeln in Zelle B5 und kopieren Sie diese nach unten: =WENN(REST(ZEILE($A5)-1;2)=0;INDEX($A$5:$A$30;(ZEILE(A5)-2)/2);"")

Sollen statt einer Leerzeile 2 Leerzeilen hinzugefügt werden, dann erfassen Sie in Zelle C5 diese Formel und kopieren diese ebenfalls so weit wie nötig nach unten: =WENN(REST(ZEILE($A5)-2;3)=0;INDEX($A$5:$A$30;(ZEILE(A5)-2)/3);"")

Diese Formeln weichen nur in ein paar Punkten voneinander ab. Dies können Sie ganz einfach sehen, wenn Sie diese beiden Formeln vergleichen.

1 Leerzeile  :  =WENN(REST(ZEILE($A5)-1;2)=0;INDEX($A$5:$A$30;(ZEILE(A5)-2)/2);"")
2 Leerzeilen: 
 =WENN(REST(ZEILE($A5)-2;3)=0;INDEX($A$5:$A$30;(ZEILE(A5)-2)/3);"")

Durch die Anpassung der rot markierten Werte, können ganz einfach auch 3, 4 oder mehrere Zeilen eingefügt werden.


Das folgende Beispiel zeigt, wie sich Blöcke von 2 bzw. 3 Zeilen bilden lassen.
Erfassen Sie dazu in Zelle D5 folgende Formel: =WENN(REST(ZEILE($A1);3)<>0;INDEX($A$5:$A$30;ZEILE()-4-GANZZAHL((ZEILE(A1)-0)/3));"")
Diese Formel sorgt dafür, dass immer zwei Werte als Block angezeigt werden und danach jeweils eine Leerzeile eingefügt wird.

Auch hier noch der Vollständigkeit halber die Formel, um Blöcke mit 3 Werte zu erzeugen: =WENN(REST(ZEILE($A1);4)<>0;INDEX($A$5:$A$30;ZEILE()-4-GANZZAHL((ZEILE(A1)-0)/4));"")

Das Ergebnis der vier Formeln sehen Sie in der folgenden Abbildung.





Drucken E-Mail

Relevante Artikel

Projektanfrage

 Sie benötigen eine Auftragsprogrammierung?
 Oder suchen Unterstützung bei der 
 Lösungsfindung?

  Nutzen Sie unser Anfrageformular

  Jetzt anrufen unter 0151 / 164 55 914

 Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! Projektanfrage per Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! senden

  Weitere Informationen

sitepanel question2

P
R
O
J
E
K
T
A
N
F
R
A
G
E
Ihre Zufriedenheit ist unser Ziel, deshalb verwenden wir Cookies. Mit diesen ermöglichen wir, dass unsere Webseite zuverlässig und sicher läuft, wir die Performance im Blick behalten und Sie besser ansprechen können. Cookies werden benötigt, damit technisch alles funktioniert und Sie auch externe Inhalte lesen können. Des Weiteren sammeln wir unter anderem Daten über aufgerufene Seiten, getätigte Käufe oder geklickte Buttons, um so unser Angebot an Sie zu Verbessern. Mehr über unsere verwendeten Dienste erfahren Sie unter „Weitere Informationen“. Mit Klick auf „Akzeptieren“ erklären Sie sich mit der Verwendung dieser Dienste einverstanden. Ihre Einwilligung können Sie jederzeit mit Wirkung auf die Zukunft widerrufen oder ändern.