Brauchen Sie Hilfe?
Web:     Online-Formular
E-Mail:  
Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!
Tel:       +49(0)151 / 164 55 914

Nutzen Sie für Ihre Anfrage unser Online-Formular oder senden Sie uns eine E-Mail an Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!. Gerne können Sie aber auch direkt telefonisch Kontakt aufnehmen.

   
     Referenzen
 Bosch 
  T-Systems
  Hagebau
  Siemens
 Areva  VW
 Haufe-Lexware  British American Tobacco
  nagel group farbe
   

Makro über die Funktion WENN() starten

Haben Sie schon mal darüber nachgedacht, über die Funktion =WENN(Prüfung;dann;sonst) ein eigenes Makro auszuführen, wenn die Wenn-Bedingung eintritt?


Nachfolgend zeigen wir Ihnen, wie sich dies relativ einfach realiseren lässt.


Erfassen Sie in eine beliebige Zelle folgende Formel: =WENN(F5="Start";Makro1_start();"nichts")


Diese Wenn-Funktion prüft, ob in Zelle F5 der Text Start eingegeben wurde. Ist dies der Fall, wird das Makro mit der Bezeichnung "Makro1_start" aufgerufen und die entsprechenden Befehle ausgeführt. Im Beispiel wird nur der Text "Makro 1 wurde gestartet" ausgegeben. Wenn in die Zelle F5 etwas anderes als Start eingetragen wird, gibt die Wenn-Funktion den Text "nichts" zurück.


Da eine Wenn-Abfrage keine Sub-Prozedur sondern nur eine Function ausführen kann, muss der Umweg gegangen werden, dass
eine Function aufgerufen wird, welche wiederum die ensprechende Sub startet, siehe nachfolgenden VBA-Code:

 

Da eine Wenn-Abfrage keine Sub-Prozedur sondern nur eine Function ausführen kann, muss der Umweg gegangen werden, dass
eine Function aufgerufen wird, welche wiederum die ensprechende Sub startet.

Function makro1_start()
'** Prozedur aufrufen
testmakro1
End Function


Sub testmakro1()
MsgBox "Makro 1 wurde gestartet"
End Sub

 

Erfassen Sie diesen Code in ein Code-Modul.


   

Relevante Artikel

  • Textbox-Eingabe mit ENTER-Taste abschließen und Aktion ausführen

    VBA-Makros können über verschiedene Ereignisse aufgerufen werden. Üblicherweise werden Makros über CommandButton, Menüpunkte in der Symbol- oder Multifunktionsleiste oder über Tastenkombinationen...

  • Zelleinträge automatisch kommentieren

    Im folgenden Beitrag zeigen wir Ihnen, wie alle Zelleinträge und Änderungen mit Hilfe der in Excel integrierten Kommentarfunktion protokolliert und historisiert werden können. Das Bild oben zeigt...

  • MessageBox nach bestimmter Zeit automatisch schließen

    Eine MessageBox wird normalerweise so lange am Bildschirm angezeigt, bis diese über eine Schaltfläche wie Ja, Nein oder OK beendet wird. Mit Hilfe des nachfolgenden Codes lässt sich eine MessageBox aber auch...

  • Makro per Doppelklick in eine Zelle starten

      Dieses Makro führt nach einem Doppelklich in die Zelle A1 ein beliebiges Makro aus.Um dies zu realisieren, wird das Worksheet Event "Worksheet_BeforeDoubleClick" verwendet. Der folgende Code muss dazu in das Codemodul eines...

  • Makro über die Funktion WENN() starten

    Haben Sie schon mal darüber nachgedacht, über die Funktion =WENN(Prüfung;dann;sonst)ein eigenes Makro auszuführen, wenn die Wenn-Bedingung eintritt? Nachfolgend zeigen wir Ihnen, wie sich dies...

   

Excel-Inside auf Facebook Excel-Live News blog Excel-Inside RSS-Feed Twitter Account für Excel-Inside Mail an Excel-Inside 

Programmierung
Excel Auftragsprogrammierung Access Auftragsprogrammierung
Word Auftragsprogrammierung Outlook Auftragsprogrammierung
   
Unsere Produkte
Office Schulungen VBA, Excel, Access
E-Book Formeln und Funktionen Excel 2013