Projektanfrage

Projektanfrage über Web Formular   per Online-Formular 
Projektanfrage über E-Mail  Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!
Projektanfrage per Telefon  +49 (0)151 / 164 55 914
Projektanfrage weitere Informationen  weitere Informationen 

Sie benötigen Hilfe oder Unter-stützung? Nutzen Sie für Ihre Anfrage unser Online-Formular, senden Sie uns eine Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! oder rufen Sie uns einfach an.

   
      Referenzen 

 Bosch 
  T-Systems
  Hagebau
  Siemens
 Areva  VW
 Haufe-Lexware  British American Tobacco
  nagel group farbe
   
     Programmierung
Excel Auftragsprogrammierung Access Auftragsprogrammierung
Word Auftragsprogrammierung Outlook Auftragsprogrammierung
   
   

Projektanfrage

 Sie benötigen eine Auftragsprogrammierung?
 Oder suchen Unterstützung bei der Lösungs-
 findung?

  Nutzen Sie unser Anfrageformular

  Jetzt anrufen unter 0151 / 164 55 914

 Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! Projektanfrage per Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! senden

  Weitere Informationen

sitepanel question2

P
r
o
j
e
k
t
a
n
f
r
a
g
e
   

Makro über die Funktion WENN() starten

Haben Sie schon mal darüber nachgedacht, über die Funktion =WENN(Prüfung;dann;sonst) ein eigenes Makro auszuführen, wenn die Wenn-Bedingung eintritt?


Nachfolgend zeigen wir Ihnen, wie sich dies relativ einfach realiseren lässt.


Erfassen Sie in eine beliebige Zelle folgende Formel: =WENN(F5="Start";Makro1_start();"nichts")


Diese Wenn-Funktion prüft, ob in Zelle F5 der Text Start eingegeben wurde. Ist dies der Fall, wird das Makro mit der Bezeichnung "Makro1_start" aufgerufen und die entsprechenden Befehle ausgeführt. Im Beispiel wird nur der Text "Makro 1 wurde gestartet" ausgegeben. Wenn in die Zelle F5 etwas anderes als Start eingetragen wird, gibt die Wenn-Funktion den Text "nichts" zurück.


Da eine Wenn-Abfrage keine Sub-Prozedur sondern nur eine Function ausführen kann, muss der Umweg gegangen werden, dass
eine Function aufgerufen wird, welche wiederum die ensprechende Sub startet, siehe nachfolgenden VBA-Code:

 

Da eine Wenn-Abfrage keine Sub-Prozedur sondern nur eine Function ausführen kann, muss der Umweg gegangen werden, dass
eine Function aufgerufen wird, welche wiederum die ensprechende Sub startet.

Function makro1_start()
'** Prozedur aufrufen
testmakro1
End Function


Sub testmakro1()
MsgBox "Makro 1 wurde gestartet"
End Sub

 

Erfassen Sie diesen Code in ein Code-Modul.


   

Relevante Artikel

  • Beim verändern einer Zelle eine Aktion ausführen

    Excel erkennt automatisch, wenn der Anwender eine Zelle verändert. So können alle oder bestimmte Zellen beliebig per VBA überwacht werden.   Das folgende Makro wird beispielsweise ausgeführt, wenn in...

  • Tischrechner mit Tippstreifen

    Der in diesem Beitrag vorgestellte Rechner protokollilert alle Eingaben in einer Art Tipp-Streifen, so wie bei Tischrechnern üblich. Damit können Eingaben nachvollzogen und historisiert werden,...

  • Ereignis beim selektieren einer Zelle ausführen

    Immer wenn in Excel eine Zelle aktiviert wird, wir das entsprechende Ereignis Worksheet_SelectionChange ausgeführt. In diesem Makro zeigen wir Ihnen, wie dies funktioniert. So soll bei Auswahl der...

  • Zähler beim Start einer Arbeitsmappe um den Wert 1 erhöhen

    Solle bei jedem Start einer Arbeitsmappe ein Zähler, beispielsweise eine Rechnungsnummer in Zelle B2, um den Wert 1 erhöht werden, dann sehen Sie sich den folgenden Code näher an. Private Sub...

  • Zelleinträge automatisch kommentieren

    Im folgenden Beitrag zeigen wir Ihnen, wie alle Zelleinträge und Änderungen mit Hilfe der in Excel integrierten Kommentarfunktion protokolliert und historisiert werden können. Das Bild oben zeigt...