Projektanfrage

Projektanfrage über Web Formular   per Online-Formular 
Projektanfrage über E-Mail  Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!
Projektanfrage per Telefon  +49 (0)151 / 164 55 914
Projektanfrage weitere Informationen  weitere Informationen 

Sie benötigen Hilfe oder Unter-stützung? Nutzen Sie für Ihre Anfrage unser Online-Formular, senden Sie uns eine Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! oder rufen Sie uns einfach an.

   
      Referenzen 

 Bosch 
  T-Systems
  Hagebau
  Siemens
 Areva  VW
 Haufe-Lexware  British American Tobacco
  nagel group farbe
   
     Programmierung
Excel Auftragsprogrammierung Access Auftragsprogrammierung
Word Auftragsprogrammierung Outlook Auftragsprogrammierung
   
   

Projektanfrage

 Sie benötigen eine Auftragsprogrammierung?
 Oder suchen Unterstützung bei der Lösungs-
 findung?

  Nutzen Sie unser Auftragsformular

  Jetzt anrufen unter 0151 / 164 55 914

 Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! Projektanfrage per Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! senden

  Weitere Informationen

sitepanel question2

P
r
o
j
e
k
t
a
n
f
r
a
g
e
   

Dynamische Bilderanzeige

In diesem Beitrag zeigen wir Ihnen, wie in einer Zelle verschiedene Bilder nach Eingabe einer Bildnummer angezeigt werden können.

Als Ausgangsbasis dient eine Sammlung von 4 Bildern, im Beispiel von 4 Flaggen, siehe Abbildung 1.


Abb. 1

Ziel ist es nun in einer anderen Zelle nach Eingabe der Bildnummer dort die jeweilige Landesflagge anzuzeigen.

Gehen Sie dazu wie folgt vor:

  1. Legen Sie zunächst eine Zelle fest, in der Sie die Zeilennummer des Bildes eintragen, welches in der neuen Zelle dynamisch angezeigt werden soll. Im Beispiel haben wir dieses Eingabefeld in Zelle E4 festgelegt.
  2. Anschließend muss ein Bereichsname definiert werden, der sich auf diese Zelle bezieht. Starten Sie dazu unter Formeln / Namensmanager den Namensmanager und legen Sie den Namen bild1 an. Im Feld "Bezieht sich auf:" erfassten Sie folgende Formel: =INDIREKT("Tabelle1!B"&Tabelle1!$E$4) und beenden das Dialogfenster wieder, siehe Abbildung 2.


    Abb. 2
  3. Im nächsten Schritt wird ein Bilderrahmen eingefügt. Klicken Sie dazu auf der Registerkarte Start / Zwischenablage / Kopieren auf den Eintrag Als Bild kopieren und bestätigen das Dialogfenster mit den Optionen "Darstellung - Wie angezeigt" und "Format - Bild", siehe Abbildung 3.


    Abb. 3

  4. Fügen Sie den Bilderrahmen nun an gewünschter Stelle, im Beispiel in Zelle E6 über den Befehl Start / Einfügen aus der Zwischenablage ein. Nach dem Einfügen befindet sich der Bilderrahmen in dieser Zelle, der durch einen grauen Rahmen zu erkennen ist.
  5. Markieren Sie den Rahmen und tragen in die Formelzeile den zuvor unter Punkt 2 angelegten Bereichsnamen ein, siehe Abbildung 4.


    Abb. 4

  6. Damit sind sämtliche Arbeiten für die Bilderanzeige erledigt. Wenn Sie nun in die Zelle E4 z. B. den Wert 7 eintragen, welcher der Zeilennummer des zweiten Bildes entspricht, so wird dieses in dem Bilderrahmen in Zelle E6 angezeigt, siehe Abbildung 5.


    Abb. 5

Ändern Sie den Eintrag in Zelle E4 auf den Wert 9, so wird automatisch die vierte Flagge in Zelle E6 angezeigt. Auf diese Weise lassen sich beliebige Bilder oder Grafiken in dem Bilderrahmen dynamisch ausgeben.

Die Beispieldatei können Sie unter dem folgenden Link herunterladen.

 

   

Relevante Artikel

  • Letzten numerischen Wert in einer Spalte ermitteln

    207078 Mit der folgenden Formel kann die letzte benutzte Ziffer aus einer Spalte ermittelt werden.Texte, Sonderzeichen, also alle nicht numerischen Werte werden dabei nicht berücksichtigt. Um...

  • Erläuterung der Blitzvorschau-Funktion

    Seit Excel 2013 steht die neue Blitzvorschau-Funktion zur Verfügung. Damit können Daten auf intelligente Art und Weise ausgelesen und verändert werden. Zum Extrahieren genügt es, ein entsprechendes...

  • Bezug der Summenformel soll erhalten bleiben

      207051     A B C 1 10 =SUMME(A1:A5) =SUMME(INDIREKT("A1"):INDIREKT("A5")) 2 10     3 10     4 10     5 10       Wird nach der Zeile 3 eine neue Zeile eingefügt, passiert folgendes: Variante in Zelle B1: Der Summenbereich erweitert...

  • Immer die gleiche Zeile aus gefilterter Liste auslesen

    Dieses Beispiel zeigt, wie immer die gleiche Zeile aus einer gefilterten Liste ausgelesen werden kann, gleichgültig wie der Filter gesetzt wird. Als Grundlage dient eine Artikelliste, siehe...

  • Eingabe von Brüchen

    Bei der Erfassung von Werten in eine Excel-Zelle greift die automatische Zahleninterpretation und versucht die Zahlen in das gewünschte Format umzuwandeln. Das funktioniert in der Regel auch ganz...