Verweis mit Suchkriterien in mehreren Spalten

Mit der Funktion =SVERWEIS() können nur Suchbegriffe in einer einzigen Spalte gesucht werden. Befinden sich die Suchbegriffe aber in zwei oder mehr Spalten, so muss die Suche über eine andere Funktion durchgeführt werden.

Folgende Daten mit 3 Suchbegriffen sollen ausgewertet werde.

So soll beispielsweise für die Suchbegrifft

Art.-Nr.: = 4712
Lagerort: = Lager B
Lagerart: = Aussen

der Wert 500 aus Zeile 10 zurückgeliefert werden, da in dieser Zeile alle drei Suchbegriffe identisch sind.

Das Ergebnis kann mit Hilfe der Funktino INDEX() in Verbindung mit der Funktion SUMMENPRODUKT() erreicht werden. Dabei handelt es sich um keine Matrixfunktion. Die Formel dazu lautet wie folgt:

=INDEX(D:D;SUMMENPRODUKT((A1:A20=H5)*(B1:B20=H6)*(C1:C20=H7)*ZEILE(1:20)))

Alternativ kann auch eine Matrix-Funktion verwendet werden, die etwas kürzer ist:

{=INDEX(D:D;VERGLEICH(H5&H6&H7;A1:A20&B1:B20&C1:C20;0))}

Hinweis:
Die geschweiften Klammern dürfen nicht eingegeben werden, sondern müssen über die Tastenkombination [Strg] + [Umschalt] + [Enter] erzeugt werden.

Das Ergebnis sieht wie folgt aus.

 

Nachfolgend können Sie die Beispieldatei mit den entsprechenden Formeln herunterladen.

 

   

Excel-Inside auf FacebookExcel-Live News blogExcel-Inside RSS-FeedMail an Excel-InsideTwitter Account für Excel-InsideMail an Excel-Inside

Office Programmierung

Excel Auftragsprogrammierung

Access Auftragsprogrammierung

Word Auftragsprogrammierung

Outlook Auftragsprogrammierung

 

 

 

 




   
Office Schulungen VBA, Excel, Access
E-Book Formeln und Funktionen Excel 2013
Excel-Inside Newsletter abonnieren
   

Backlink  

ERROR: PAGE_URL belons not to given domain: 573001800