Brauchen Sie Hilfe?
Web:     Online-Formular
E-Mail:  
Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!
Tel:       +49(0)151 / 164 55 914

Nutzen Sie für Ihre Anfrage unser Online-Formular oder senden Sie uns eine E-Mail an Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!. Gerne können Sie aber auch direkt telefonisch Kontakt aufnehmen.

   
     Referenzen
 Bosch 
  T-Systems
  Hagebau
  Siemens
 Areva  VW
 Haufe-Lexware  British American Tobacco
  nagel group farbe
   

Trennen von Texten unterschiedlicher Länge

207069



Die folgende Funktion trennt Texte unterschiedlicher, unbekannter Länge bei der ersten Leerstelle. Gerade nach Datenimporten befinden sich oft Vor- und Nachname in einer Zelle.

Wollen sie Daten z. B. in eine Datenbank übernehmen, müssen solche Zellen in
einzelne Felder (Zellen) aufgeteilt werden.
  A B C
1 Hans Muster =LINKS(A1;FINDEN(" ";A1;1)-1) =TEIL(A1;FINDEN(" ";A1;1)+1;LÄNGE(A1))
2 1234567 89101112 =LINKS(A2;FINDEN(" ";A2;1)-1) =TEIL(A2;FINDEN(" ";A2;1)+1;LÄNGE(A2))
3 Winfrid Will =LINKS(A3;FINDEN(" ";A3;1)-1) =TEIL(A3;FINDEN(" ";A3;1)+1;LÄNGE(A3))


Handelt es sich beim Trennzeichen nicht um eine Leerstelle sonder z. B. um ein ; oder , so müssen Sie dies entsprechend in der Funktion angeben; also z. B: so:

=LINKS(A1;FINDEN(",";A1;1)-1)

   

Relevante Artikel

  • Zellinhalte verstecken

    Es kommt immer wieder vor, dass Zellinhalte versteckt werden sollen. Sei es, um Inhalte vor neugierigen Blicken zu verbergen oder um Kalkulationen übersichtlicher zu gestalten, indem Informationen...

  • Aufgabenliste mit Statusampel

    Dieser Tipp zeigt eine Aufgabenliste mit einer Statusampel. Damit kann jeder Aufgabe durch Auswahl verschiedenen Status grün, gelb und rot die entsprechende Ampelanzeige zugewiesen werden. Die...

  • Verweis mit Suchkriterien in mehreren Spalten

    Mit der Funktion =SVERWEIS() können nur Suchbegriffe in einer einzigen Spalte gesucht werden. Befinden sich die Suchbegriffe aber in zwei oder mehr Spalten, so muss die Suche über eine andere...

  • Gruppierungslinien in Listen einfügen

    Gruppierungslinien sorgen in umfangreichen Listen für mehr Übersicht. Im Beispiel liegt eine sortierte Liste mit Namen vor. Ziel ist, dass nach jedem geänderten Anfangsbuchstaben eine Gruppierungs-...

  • Daten-Tabelle in Excel 2007 erstellen

    Excel 2007 bietet mit der neuen Datentabellenfunktion eine wenig bekannte Erweiterung. Mit einem Klick lässt sich eine Datentabelle erstellen, welche beliebig formatiert werden kann. Neben der...

   

Excel-Inside auf Facebook Excel-Live News blog Excel-Inside RSS-Feed Twitter Account für Excel-Inside Mail an Excel-Inside 

Programmierung
Excel Auftragsprogrammierung Access Auftragsprogrammierung
Word Auftragsprogrammierung Outlook Auftragsprogrammierung
   
Unsere Produkte
Office Schulungen VBA, Excel, Access
E-Book Formeln und Funktionen Excel 2013