Brauchen Sie Hilfe?
Web:     Online-Formular
E-Mail:  
Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!
Tel:       +49(0)151 / 164 55 914

Nutzen Sie für Ihre Anfrage unser Online-Formular oder senden Sie uns eine E-Mail an Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!. Gerne können Sie aber auch direkt telefonisch Kontakt aufnehmen.

   
     Referenzen
 Bosch 
  T-Systems
  Hagebau
  Siemens
 Areva  VW
 Haufe-Lexware  British American Tobacco
  nagel group farbe
   

Dateiname in Zellen einfügen

207072



Um den Dateinamen inkl. Pfadangabe und Tabellenblatt in eine Zelle einzufügen kann folgende Funktion verwendet werden:

=ZELLE("Dateiname";A1)


Der Dateiname wird mit dieser Funktion allerdings in eckigen Klammern angezeigt Bspw. [datei.xls].
Möchten Sie nun den gesamten Pfad ohne Klammern anzeigen so hilft Ihnen diese Funktion weiter:

=WECHSELN(WECHSELN(ZELLE("Dateiname";A1);"[";"");"]";"")


Soll hingegen nur der Dateiname eingefügt werden, so ist eine etwas umfangreichere Funktion notwendig:

=TEIL(ZELLE("Dateiname";A1);SUCHEN("[";ZELLE("Dateiname";A1);1)+1;SUCHEN("]";ZELLE("Dateiname";A1);1)-SUCHEN("[";ZELLE("Dateiname";A1);1)-1)

Wichtig ist hier, dass nach Dateiname die Zelle A1 angegeben wird, da sonst in einigen Fällen der Dateiname nicht aktualisiert wird.


 

   

Relevante Artikel

  • Bezeichnung / Name des Tabellenblatts auslesen

    In vielen Situationen wird die Bezeichnung des Tabellenblattes benötigt, bspw. wenn in einer Formel Bezug auf ein anderes Tabellenblatt genommen wird. Der Blattname kann entweder über eine Formel- oder...

  • Fortlaufende Nummerierung bei ausgeblendeten Zeilen

    In diesem Beitrag habe ich bereits vor einiger Zeit einen Lösungsvorschlag für eine laufende Nummerierung bei Verwendung des Autofilters vorgestellt. Heute möchte ich Ihnen zeigen, wie Sie die fast...

  • Summierung abhängig vom Datum

    201004 Mit der nachfolgenden Funktion werden die Werte in Spalte B1 bis B15 addiert, wenn das das Datum aus Spalte A1 bis A15 im Monat Februar liegt. Beispiel:   A B C 1 01.01.2003 5   2 01.01.2003 1   3...

  • Ermittlung des letzten Wertes einer Zeile oder Spalte

    Immer wieder kommt die Fragestellung auf, wie aus einer Liste der letzte Eintrag aus einer Zeile oder Spalte ermittelt und ausgelesen werden kann. A) Das erste Beispiel zeigt, wie der letzte Eintrag...

  • Zeilen in 3er-Schritten nummerieren

    Sie möchten z. B. die Spalte A in 3er-Schritten nummerieren? Dann tragen Sie folgende Formel in Zelle A1 bzw. in die gewünschte Startzelle ein. =WENN(REST(ZEILE();3)=0;ZEILE();"") Kopieren Sie die...

   

Excel-Inside auf Facebook Excel-Live News blog Excel-Inside RSS-Feed Twitter Account für Excel-Inside Mail an Excel-Inside 

Programmierung
Excel Auftragsprogrammierung Access Auftragsprogrammierung
Word Auftragsprogrammierung Outlook Auftragsprogrammierung
   
Unsere Produkte
Office Schulungen VBA, Excel, Access
E-Book Formeln und Funktionen Excel 2013