Brauchen Sie Hilfe?
Web:     Online-Formular
E-Mail:  
Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!
Tel:       +49(0)151 / 164 55 914

Nutzen Sie für Ihre Anfrage unser Online-Formular oder senden Sie uns eine E-Mail an Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!. Gerne können Sie aber auch direkt telefonisch Kontakt aufnehmen.

   
     Referenzen
 Bosch 
  T-Systems
  Hagebau
  Siemens
 Areva  VW
 Haufe-Lexware  British American Tobacco
  nagel group farbe
   

Daten lückenlos auflisten

In diesem Beispiel liegen die Ausgangsdaten im Zellbereich B5 bis B25 Daten vor. Diese beinhalten abwechselnd Einträge und leere Zellen. Ziel ist es nun, die Daten lückenlos, also ohne Leerzeilen auszulesen und entsprechend aufzulisten.

Die folgende Abbildung zeigt die Ausgangsdaten:

 
Abb 1: Ausgangsdaten inkl. Datenlücken

Ab Zelle D5 sollen die Daten nun ohne Leerzeilen ausgelesen werden. Es sollen also alle Einträge aus dem Bereich B5:B25 ohne Leerzeilen untereinander aufgelistet werden.

Gehen Sie dazu wie folgt vor:

  1. Erfassen Sie folgende Formel in Zelle D5
    {=WENN(ZEILE(B1)>ANZAHL2($B$5:$B$25);"";INDEX($B:$B;KKLEINSTE(WENN(B$5:B$25<>"";
    ZEILE($5:$25));ZEILE(A1))))}

  2. Da es sich um eine Matrixfunktion handelt, dürfen die geschweiften Klammern nicht manuell eingegeben werden. Wenn Sie die Eingabe mit der Tastenkombination [Strg] + [Umschalt] + [Enter] abschließen, werden die geschweiften Klammern automatisch hinzugefügt und Excel interpretiert die Formel korrekt als Matrixfunktion.
  3. Kopieren Sie im letzten Schritt diese Formeln nun noch bis zur Zelle D25 nach unten. Damit werden alle Daten aus dem Ausgangsbereich ausgelesen.

Wie Sie sehen, werden im Ergebnis wie gewünscht alle Daten ohne Leerzellen ausgegeben, siehe Abbildung 2.


Abb. 2: Lückenlose Anzeige der Daten

 

 

   

Relevante Artikel

  • Ermittlung des letzten Wertes einer Zeile oder Spalte

    Immer wieder kommt die Fragestellung auf, wie aus einer Liste der letzte Eintrag aus einer Zeile oder Spalte ermittelt und ausgelesen werden kann. A) Das erste Beispiel zeigt, wie der letzte Eintrag...

  • Fehlerwerte beim Drucken unterdrücken

    In Ihrer Excel-Datei befinden sich Fehler wie beispielsweise #DIV/0!, #WERT, #NV oder andere Fehlerwerte. Diese Fehlerwerte lassen sich für den Ausdruck unterdrücken, bspw. wenn Sie eine erste...

  • Bezug der Summenformel soll erhalten bleiben

      207051     A B C 1 10 =SUMME(A1:A5) =SUMME(INDIREKT("A1"):INDIREKT("A5")) 2 10     3 10     4 10     5 10       Wird nach der Zeile 3 eine neue Zeile eingefügt, passiert folgendes: Variante in Zelle B1: Der Summenbereich erweitert...

  • Excel 2013: Die neue Funktion 'Quick Analysis'

    Heute stelle ich euch die neue Funktion Quick Analysis von Excel Office 2013 vor. Wie der Name schon sagt, können mit dieser neuen Funktion Daten einfach und schnell analysiert und mit zusätzlichen...

  • Anzahl Wörter in einer Zelle zählen

    Sie möchten die Anzahl der in einer Zelle vorhandenen Wörter zählen? Mit der folgenden Funktion kommen Sie zum Ziel: =LÄNGE(A1)-LÄNGE(WECHSELN(A1;" ";))+1   Wenn in Zelle A1 beispielsweise dieser Text...

   

Excel-Inside auf Facebook Excel-Live News blog Excel-Inside RSS-Feed Twitter Account für Excel-Inside Mail an Excel-Inside 

Programmierung
Excel Auftragsprogrammierung Access Auftragsprogrammierung
Word Auftragsprogrammierung Outlook Auftragsprogrammierung
   
Unsere Produkte
Office Schulungen VBA, Excel, Access
E-Book Formeln und Funktionen Excel 2013