Daten lückenlos auflisten

In diesem Beispiel liegen die Ausgangsdaten im Zellbereich B5 bis B25 Daten vor. Diese beinhalten abwechselnd Einträge und leere Zellen. Ziel ist es nun, die Daten lückenlos, also ohne Leerzeilen auszulesen und entsprechend aufzulisten.

Die folgende Abbildung zeigt die Ausgangsdaten:

 
Abb 1: Ausgangsdaten inkl. Datenlücken

Ab Zelle D5 sollen die Daten nun ohne Leerzeilen ausgelesen werden. Es sollen also alle Einträge aus dem Bereich B5:B25 ohne Leerzeilen untereinander aufgelistet werden.

Gehen Sie dazu wie folgt vor:

  1. Erfassen Sie folgende Formel in Zelle D5
    {=WENN(ZEILE(B1)>ANZAHL2($B$5:$B$25);"";INDEX($B:$B;KKLEINSTE(WENN(B$5:B$25<>"";
    ZEILE($5:$25));ZEILE(A1))))}

  2. Da es sich um eine Matrixfunktion handelt, dürfen die geschweiften Klammern nicht manuell eingegeben werden. Wenn Sie die Eingabe mit der Tastenkombination [Strg] + [Umschalt] + [Enter] abschließen, werden die geschweiften Klammern automatisch hinzugefügt und Excel interpretiert die Formel korrekt als Matrixfunktion.
  3. Kopieren Sie im letzten Schritt diese Formeln nun noch bis zur Zelle D25 nach unten. Damit werden alle Daten aus dem Ausgangsbereich ausgelesen.

Wie Sie sehen, werden im Ergebnis wie gewünscht alle Daten ohne Leerzellen ausgegeben, siehe Abbildung 2.


Abb. 2: Lückenlose Anzeige der Daten

 

 

   

Excel-Inside auf FacebookExcel-Live News blogExcel-Inside RSS-FeedMail an Excel-InsideTwitter Account für Excel-InsideMail an Excel-Inside

Office Programmierung

Excel Auftragsprogrammierung

Access Auftragsprogrammierung

Word Auftragsprogrammierung

Outlook Auftragsprogrammierung

 

 

 

 




   
Office Schulungen VBA, Excel, Access
E-Book Formeln und Funktionen Excel 2013
Excel-Inside Newsletter abonnieren
   

Backlink  

ERROR: PAGE_URL belons not to given domain: 573001800