Projektanfrage

Projektanfrage über Web Formular   per Online-Formular 
Projektanfrage über E-Mail  Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!
Projektanfrage per Telefon  +49 (0)151 / 164 55 914
Projektanfrage weitere Informationen  weitere Informationen 

Sie benötigen Hilfe oder Unterstützung? Nutzen Sie für Ihre Anfrage unser Online-Formular, senden Sie uns eine Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!  oder rufen Sie uns einfach an.

Referenzen

 Bosch 
  T-Systems
  Hagebau
  Siemens
 Areva  VW
 Haufe-Lexware  British American Tobacco
  nagel group farbe

Anzahl der Einträge innerhalb einer Zelle ermitteln

Die in diesem  Beispiel vorgestellte Formel zählt die mit einem Trennzeichen wie beispielsweise Komma (,) oder Semikolon (;) getrennte Einträge innerhalb einer Zelle.

1. Im ersten Beispiel befinden sich in Zelle A2 folgende Einträge: Müller, Meier, Schmid, Eckl

Tragen Sie in Zelle B2 folgende Formel ein:
=WENN(LÄNGE(GLÄTTEN(A2))=0;0;LÄNGE(GLÄTTEN(A2))-LÄNGE(WECHSELN(A2;",";""))+1)

Da als Trennzeichen in der Zelle ein Komma verwendet wurde, muss dieses entsprechend in der Formel angegeben werden, siehe rote Markierung.

Das Ergebnis lautet 4, da vier verschiedene Namen in der Zelle vorhanden sind.

2. Im zweiten Beispiel befinden sich in Zelle A2 folgende Einträge: Max; Klaus; Birgit

Um die Anzahl zu Ermitteln tragen Sie in Zelle B2 folgende, leicht veränderte Formel ein:
=WENN(LÄNGE(GLÄTTEN(A2))=0;0;LÄNGE(GLÄTTEN(A2))-LÄNGE(WECHSELN(A2;";";""))+1)

Die Einzige Änderung ist, dass als Suchkriterium für die Funktion das Semikolon (;) anstatt das Komma (,) angegeben wird. Das Ergebnis der Formel lautet 3.

3. Im Dritten Beispiel wurde kein explizites Trennzeichen verwendet, sondern es befinden sich nur Leerzeichen zwischen den Einträgen in Zelle A2: München Stuttgart Nürnberg Berlin Köln

Auch diese Art der Trennung kann mit der vorliegenden Formel problemlos verarbeitet werden. Ändern Sie dazu die Formel wie folgt ab:

=WENN(LÄNGE(GLÄTTEN(A2))=0;0;LÄNGE(GLÄTTEN(A2))-LÄNGE(WECHSELN(A2;" ";""))+1)

Mit dieser Änderung sucht die Formel nach einem Leerzeichen als Trennzeichen und liefert als Ergebnis den Wert 5 zurück.

Drucken

Relevante Artikel

  • Prüfen, ob ein bestimmter Wert in einer Liste vorkommt

    207060 Im Bereich A1:A5 steht eine Liste von Namen. In B1 steht der Wert, der überprüft werden soll, ob er in der Matrix A1:A5 vorhanden ist.   A B 1...

  • Excel 2013: Die neue Funktion 'Quick Analysis'

    Heute stelle ich euch die neue Funktion Quick Analysis von Excel Office 2013 vor. Wie der Name schon sagt, können mit dieser neuen Funktion Daten...

  • Anzahl Wörter in einer Zelle zählen

    Sie möchten die Anzahl der in einer Zelle vorhandenen Wörter zählen? Mit der folgenden Funktion kommen Sie zum Ziel: =LÄNGE(A1)-LÄNGE(WECHSELN(A1;" ";))+1   Wenn in Zelle...

  • Excel 2010 - Das Backend

    In Excel Excel 2010 sind alle Optionen und die Einstellungsmöglichkeiten, welche sich auf das Programm beziehen im sogenannten Backend...

  • Tabellennavigation mit Hyperlink

    Die in Abb. 2  zu sehende Tabellennavigation funktioniert wie folgt. 1. Es werden 5 Grafiken, im Beispiel mit der Bezeichnung Sheet1bis Sheet5 im...

Projektanfrage

 Sie benötigen eine Auftragsprogrammierung?
 Oder suchen Unterstützung bei der 
 Lösungsfindung?

  Nutzen Sie unser Anfrageformular

  Jetzt anrufen unter 0151 / 164 55 914

 Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! Projektanfrage per Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! senden

  Weitere Informationen

sitepanel question2

P
R
O
J
E
K
T
A
N
F
R
A
G
E
Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Bestätigung erklären Sie sich mit der Verwendung von Cookies auf Excel-Inside Solutions einverstanden.
Weitere Informationen Ok