Auftragsprogrammierung

Projektanfrage über Web Formular   per Online-Formular 
Projektanfrage über E-Mail  Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!
Projektanfrage per Telefon  +49 (0)151 / 164 55 914
Projektanfrage weitere Informationen  weitere Informationen 

Sie benötigen Hilfe oder Unterstützung? Nutzen Sie für Ihre Anfrage unser Online-Formular, senden Sie uns eine Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!  oder rufen Sie uns einfach an.

Referenzen

 Bosch 
  T-Systems
  Hagebau
  Siemens
 Areva  VW
 Haufe-Lexware  British American Tobacco
  nagel group farbe

DropDown-Box mit Einmalauswahl

DropDown-Felder sind eine sehr gute und beliebte Funktion, um in Excel vordefinierte Einträge zur Verfügung zu stellen. Offiziell lautet die Funktion Datenüberprüfung und wird über das Menü Daten / Datentools / Datenüberprüfung aufgerufen.

In diesem Beitrag zeigen wir Ihnen eine Erweiterung der herkömmlichen Datenüberprüfung. Normalerweise kann der im DropDown-Feld hinterlegte Eintrag beliebig oft auf einem Blatt ausgewählt und entsprechend eingefügt werden. Mit der nachfolgend erläuterten Erweiterung wird das DropDown-Feld so angepasst, dass jeder Eintrag nur ein einziges Mal auf das Blatt bzw. innerhalb eines definierten Zellbereichs eingefügt werden kann.

Dazu erstellen wir im ersten Schritt eine Liste mit den Einträgen, welche im DropDown-Menü angezeigt werden sollen, siehe Abbildung 1.

dropdown einmalauswahl 1
Abbildung 1

Damit die DropDown-Box den einmal eingetragenen Begriff nicht mehr anzeigt, muss diese Tabelle etwas dynamisiert werden.
  1. In Spalte B (Menü-Einträge) werden die Begriffe eingetragen, welche im DropDown-Feld angezeigt werden sollen.

  2. In Zelle C7 (Spalte verfügbar)  wird aufgelistet, welche Einträge noch nicht ausgewählt wurden. Erfassen Sie dazu folgende Formel und kopieren diese bis zum letzten Eintrag in Zelle C22 nach unten:  =WENN(ZÄHLENWENN (Übersicht!$C$4:$C$40; Auswahl!B7) =0;ZEILEN(Auswahl!$B$7:B7);"")

  3. In Spalte D (vergeben) werden die Datensätze markiert, welche bereits über die DropDown-Box ausgewählt wurden und im Ausgabebereich vorhanden ist. Tragen Sie dazu in zelle D7 diese Formel ein. =WENNFEHLER (KKLEINSTE ($C$7:$C$22; ZEILEN($C$7:C7));"") Kopieren Sie diese ebenfalls bis zum letzten Eintrag in Zelle D22 nach unten. 

  4. In Spalte D (Dropdown) werden nun mit der Formel =WENNFEHLER (INDEX($B$7:$B$22;D7) ;"")  die Einträge für das DropDown-Menü aufgelistet. Diese Liste stellt somit den Inhalt der DropDown-Box dar.

  5. Damit dieser Inhalt in der Gültigkeitsprüfung verwendet werden kann, muss dafür ein benutzerdefinierter Name erzeugt werden. Rufen Sie dazu über das Menü Formeln / Definierte Namen / Namens-Manager das gleichnamige Dialogfenster auf. Erstellen Sie den Namen Auswahl_1 und hinterlegen Sie dem Namen folgende Formel: =WENN(ANZAHL (Auswahl!$D$7:$D$22) =0;Auswahl!$E$7; Auswahl!$E$7:INDEX (Auswahl!$E$7:$E$22; ANZAHL(Auswahl!$D$7:$D$22))), siehe Abbildung 2.
    Diese Formel übergibt dem Namen dynamisch die jeweils gültigen Einträge.

    dropdown einmalauswahl 2
    Abbildung 2

  6. Damit sind alle Vorarbeiten erledigt und die Gültigkeitsprüfung kann auf einem beliebigen Tabellenblatt eingefügt werden.

    Gehen Sie dazu einfach wie folgt vor: 
    Markieren Sie dazu im ersten Schritt einen beliebigen Zellbereich. Im Beispiel den Bereich C4:C20 auf dem Blatt Übersicht
    Starten Sie die Gültigkeitsprüfung über das Menü Daten / Datentools / Datenüberprüfung
    Wählen Sie im Feld Zulassen den Eintrag Liste und erfassen im Feld Quelle den  unter Punkt 5 definierten Namen =Auswahl_1, siehe Abbildung 3

    dropdown einmalauswahl 3
    Abbildung 3

  7. Nach der Bestätigung mit der Schaltfläche OK steht das dynamische DropDown-Feld mit der integrierten Einmal-Auswahl von Einträgen im gewünschten Zellbereich zur Verfügung.

Das folgende Video zeigt die Funktionsweise.


Video zur Funktionsweise


Die Beispieldatei steht über den folgenden Link zum Download zur Verfügung.

Drucken E-Mail

Relevante Artikel

Projektanfrage

 Sie benötigen eine Auftragsprogrammierung?
 Oder suchen Unterstützung bei der 
 Lösungsfindung?

  Nutzen Sie unser Anfrageformular

  Jetzt anrufen unter 0151 / 164 55 914

 Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! Projektanfrage per Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! senden

  Weitere Informationen

sitepanel question2

P
R
O
J
E
K
T
A
N
F
R
A
G
E
Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Bestätigung erklären Sie sich mit der Verwendung von Cookies auf Excel-Inside Solutions einverstanden.