Projektanfrage

Projektanfrage über Web Formular   per Online-Formular 
Projektanfrage über E-Mail  Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!
Projektanfrage per Telefon  +49 (0)151 / 164 55 914
Projektanfrage weitere Informationen  weitere Informationen 

Sie benötigen Hilfe oder Unter-stützung? Nutzen Sie für Ihre Anfrage unser Online-Formular, senden Sie uns eine Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! oder rufen Sie uns einfach an.

   
      Referenzen 

 Bosch 
  T-Systems
  Hagebau
  Siemens
 Areva  VW
 Haufe-Lexware  British American Tobacco
  nagel group farbe
   
     Programmierung
Excel Auftragsprogrammierung Access Auftragsprogrammierung
Word Auftragsprogrammierung Outlook Auftragsprogrammierung
   
   

Projektanfrage

 Sie benötigen eine Auftragsprogrammierung?
 Oder suchen Unterstützung bei der Lösungs-
 findung?

  Nutzen Sie unser Anfrageformular

  Jetzt anrufen unter 0151 / 164 55 914

 Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! Projektanfrage per Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! senden

  Weitere Informationen

sitepanel question2

P
r
o
j
e
k
t
a
n
f
r
a
g
e
   

Tabellen dynamisch auswerten

Dieses Beispiel zeigt, wie eine Tabelle individuell ausgewertet werden kann. In Abbildung 1 sehen Sie die Ausgangstabelle.


Abbildung 1

Aufgabe ist nun, den Mittelwert für die Jahre 2010 bis 2013 getrennt nach Produkten (Jeans, Pulli, T-Shirt) und Namen (Max, Moritz, Maria, Monika) in einer Übersichtstabelle zu berechnen, siehe Abbildung 2.


Abbildung 2

Die erste Variante kommt ganz ohne Hilfszeilen aus.

Erfassen Sie dazu einfach in Zelle B14 folgende Formel:

=MITTELWERT(INDIREKT(ADRESSE(ZEILE()-(9+(ZEILE()-14));(SPALTE()-2)*3+(ZEILE()-12))):INDIREKT(ADRESSE(ZEILE()-(6+(ZEILE()-14));(SPALTE()-2)*3+(ZEILE()-12))))

Kopieren Sie diese Formel bis zu Zelle E14 nach rechts und bis zur Zeile 16 nach unten.

Soll diese Formel an eine andere Stelle eingefügt werden, so muss die Formel entsprechend angepasst werden. Das Ergebnis sehen Sie in Abbildung 3.


Abbildung 3

Variante 2 benötigt eine Hilfstabelle. Dafür ist die Formel etwas übersichtlicher und leichter nachzuvollziehen.

Erfassen zunächst die Hilfstabelle an einer beliebigen Stelle auf dem Tabellenblatt. Die Hilfstabelle enthält die Spalten- und Zeilennummer, in denen sich die jeweiligen Informationen befinden, siehe Abbildung 4.


Abbildung 4

Mit Hilfe der Funktion INDIREKT, werden nun die Spalten und Zeilenbezüge aus der Hilfstabelle ausgelesen und dementsprechend der Mittelwert berechnet.

Die Formel für die Berechnung des Mittelwerts für Hans / Jeans lautet demnach wie folgt:

=MITTELWERT(INDIREKT(B25 & $G$25 &":" & B25 & $G$26))

Da diese Formel ebenfalls komplett dynamisch aufgebaut ist, kann diese auch ohne jegliche Anpassung in die restlichen Zellen ohne Anpassungsbedarf kopiert werden.

Das Ergebnis sehen Sie in Abbildung 5.


Abbildung 5

Die Beispieldatei können Sie über den folgenden Link herunterladen.

 

 

   

Relevante Artikel

  • Tabellen dynamisch auswerten

    Dieses Beispiel zeigt, wie eine Tabelle individuell ausgewertet werden kann. In Abbildung 1 sehen Sie die Ausgangstabelle. Abbildung 1 Aufgabe ist nun, den Mittelwert für die Jahre 2010 bis 2013...

  • Excel 2013: Direkt mit leerer Tabelle starten

    Bis Excel 2010 startete Excel immer mit einer leeren Arbeitsmappe. Dies hat sich ab Excel 2013 (Office 2013) geändert. Dort wird standardmäßig eine Startseite angezeigt, auf der verschiedene...

  • Maßeinheiten umrechnen

    207064 Mit der Funktion UMWANDELN können Werte in verschiedene Maßeinheiten umgerechnet werden. Umwandlung von Zoll in Meter funktioniert z. B. so: =UMWANDELN(A4;"in";"m") Der Inhalt der Zelle A4...

  • Erzeugung von zufälligen Zeichenfolgen mit Regeln

    In diesem Beitrag zeigen wir Ihnen, wie sich unter Vorgabe verschiedener Prämissen eine Zufallszeichenfolge erstellen lässt. Entstanden ist die Idee durch einen Frage in unserem Forum...

  • Einfache Erfassung von Formeln und Berechnungen mit Hilfe des [+]-Zeichens

    Wenn Sie beispielsweise über den Nummernblock Zahlen addieren möchten, so beginnen Sie in der Regel die Eingabe mit einem [=]-Zeichen. Da sich dieses Zeichen jedoch nicht am Zehnerblock befindet, müssen...