Projektanfrage

Projektanfrage über Web Formular   per Online-Formular 
Projektanfrage über E-Mail  Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!
Projektanfrage per Telefon  +49 (0)151 / 164 55 914
Projektanfrage weitere Informationen  weitere Informationen 

Sie benötigen Hilfe oder Unter-stützung? Nutzen Sie für Ihre Anfrage unser Online-Formular, senden Sie uns eine Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! oder rufen Sie uns einfach an.

   
      Referenzen 

 Bosch 
  T-Systems
  Hagebau
  Siemens
 Areva  VW
 Haufe-Lexware  British American Tobacco
  nagel group farbe
   
     Programmierung
Excel Auftragsprogrammierung Access Auftragsprogrammierung
Word Auftragsprogrammierung Outlook Auftragsprogrammierung
   
   

Projektanfrage

 Sie benötigen eine Auftragsprogrammierung?
 Oder suchen Unterstützung bei der Lösungs-
 findung?

  Nutzen Sie unser Anfrageformular

  Jetzt anrufen unter 0151 / 164 55 914

 Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! Projektanfrage per Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! senden

  Weitere Informationen

sitepanel question2

P
r
o
j
e
k
t
a
n
f
r
a
g
e
   

Erzeugung von zufälligen Zeichenfolgen mit Regeln

In diesem Beitrag zeigen wir Ihnen, wie sich unter Vorgabe verschiedener Prämissen eine Zufallszeichenfolge erstellen lässt. Entstanden ist die Idee durch einen Frage in unserem Forum Office-Fragen.de. Das vorliegende Beispiel soll dabei Methoden vermitteln, die auf die eigenen Anforderungen hin adaptiert werden können.

Die zufällige Zeichenfolge soll folgende Spezifikationen berücksichtigen:

  • Die Zeichenfolge soll 6 Zeichen lang sein
  • Bestehend aus immer je drei Zahlen (0-9) und drei Großbuchstaben (A-Z)
  • Die Position von Zahlen oder Buchstaben muss variieren

Um dies zu realisieren sind ein paar Hilfszeilen notwendig, siehe Abbildung.


Abb. 1

In der ersten Hilfszeile wird mittels des Zufallsgenerators =ZUFALLSZAHL() für die ersten drei Zeichen festgelegt, ob es um eine Ziffer oder um einen Buchstaben handelt. Bei der Zufallszahl 0 handelt es sich um eine Ziffer und bei der 1 um einen Buchstaben. Dies erfolgt ganz einfach mit dieser Formel: =RUNDEN(ZUFALLSZAHL();0)

Bei den letzten drei Stellen wird geprüft, wie viele Buchstaben (1) schon vorhanden sind und abhängig davon wird entweder eine 0 (Ziffer) oder eine 1 Buchstabe gesetzt. Die Formeln dazu lautet wie folgt: =WENN(SUMME($B$5:$D$5)<3;1;0), siehe auch Abb.1.

Damit ist bereits sichergestellt, dass sich immer 3 Ziffern und 3 Buchstaben an unterschiedlichen Positionen ergeben.

Nun müssen im nächsten Schritt noch die entsprechenden Ziffern und Buchstaben ausgelesen werden. Dies lässt sich ganz einfach mit folgender Formel in Zelle B9 bis G9 realisieren: =WENN(B5=0;ZUFALLSBEREICH(1;9);ZEICHEN(ZUFALLSBEREICH(65;90)))

Diese Formel prüft, ob es sich in der Hilfszeile 5 um eine 0 handelt und ermittelt dementsprechend über die Funktion ZUFALLSBEREICH() eine Ziffer zwischen 1 und 9. Steht in der jeweiligen Hilfszelle in Zeile 5 hingegeben eine 1 wird ein zufälliges ASCII-Zeichen aus dem ASCII-Bereich 65-90 ermittelt. Der ASCII-Wert 65 steht dabei für das große A und 90 für das große Z.

Damit ist die zufällige Zeichenfolge fast fertig. Sie muss nur noch zu einem String zusammengefasst werden. Dazu kann folgende Formel verwendet werden: =B9&C9&D9&E9&F9&G9

Das war´s. Bei jeder Neuberechnung mit der Taste [F9] oder bei Änderung des Tabellenblatts wird eine neue zufällige 6-stellige Zeichenfolge ermittelt.

Mit diesem Beispiel möchten wir Ihnen zeigen, dass sich mit Excel verschiedene Berechnungen schnell und effizient durchführen lassen.

Die Beispieldatei können Sie über den folgenden Link herunterladen.

   

Relevante Artikel

  • Der Formeleditor - Videoanleitung

    Ab Excel 2010 steht nun auch einen Formeleditor zur Verfügung, mit dem beliebige Formeln grafisch dargestellt werden können. Das folgende Kurz-Video zeigt eine kleine Schritt für Schritt Anleitung...

  • Zahl mit gewählter Währung formatieren

    In diesem Beispiel zeigen wir Ihnen, wie Sie abhängig von der gewählten Währung beliebige Zellen in der gewählten Währung formatieren können. Das Beispiel ist gültig ab Excel 2007. Angenommen es...

  • Bezeichnung / Name des Tabellenblatts auslesen

    In vielen Situationen wird die Bezeichnung des Tabellenblattes benötigt, bspw. wenn in einer Formel Bezug auf ein anderes Tabellenblatt genommen wird. Der Blattname kann entweder über eine Formel- oder...

  • Excel-Datei wird aus dem Windows-Explorer heraus nicht geöffnet

    Wenn sich nach einem Doppelklick auf eine Excel-Datei im Windows-Explorer diese nicht mehr öffnen lässt, dann könnte es mit großer Wahrscheinlichkeit an einem Haken unter Optionen liegen.In Excel...

  • Excel 2013: Neue Diagramm-Funktionen

    Heute möchte ich euch die neuen Diagrammfunktionen von Excel 2013 vorstellen. Die Erstellung von Diagrammen hat wohl die größte Veränderung in Excel 2013 erfahren. Als Ausgangsdatei für die...