Zuordnen von Suchtreffern in einer Liste

Diese Beispiel zeigt, wie Suchbegriffe in einer Liste gesucht werden und die Zeile des Treffers entsprechend ermittelt wird.

Als Ausgangsbasis liegen zwei Tabellen vor. Die erste Tabelle (Tabelle A) enthält Artikelnummern in beliebiger Reihenfolge, siehe Abbildung 1.


Abbildung 1

In der zweiten Tabelle (Tabelle B, Abbildung 2) befindet sich eine Liste der Artikelnummern, deren Preis erhöht wurde.


Abbildung 2

Ziel ist es nun, die Artikel in der ersten Tabelle zu kennzeichnen, die auf der zweiten Tabelle enthalten sind, also eine Preiserhöhung erfahren haben. Dazu soll in Spalte B der ersten Liste (Tabelle A) die Zeilennummer der zweiten Tabelle (Tabelle B) eingetragen werden.

Verwenden Sie dazu folgende Formel in Zelle B4 in Tabelle A:

=WENN(ISTFEHLER(VERGLEICH(A4;TabelleB!$A$4:$A$50;0));"";VERGLEICH(A4;TabelleB!$A$4:$A$50;0))

Mit Hilfe der Funktion VERGLEICH(), lässt sich die Zeilennummer relativ einfach auslesen. Das Ergebnis sehen Sie in Abbildung 3.


Abbildung 3

 

 

   

Excel-Inside auf FacebookExcel-Live News blogExcel-Inside RSS-FeedMail an Excel-InsideTwitter Account für Excel-InsideMail an Excel-Inside

Office Programmierung

Excel Auftragsprogrammierung

Access Auftragsprogrammierung

Word Auftragsprogrammierung

Outlook Auftragsprogrammierung

 

 

 

 




   
Office Schulungen VBA, Excel, Access
E-Book Formeln und Funktionen Excel 2013
Excel-Inside Newsletter abonnieren
   

Backlink  

ERROR: PAGE_URL belons not to given domain: 573001800