Projektanfrage

Projektanfrage über Web Formular   per Online-Formular 
Projektanfrage über E-Mail  Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!
Projektanfrage per Telefon  +49 (0)151 / 164 55 914
Projektanfrage weitere Informationen  weitere Informationen 

Sie benötigen Hilfe oder Unter-stützung? Nutzen Sie für Ihre Anfrage unser Online-Formular, senden Sie uns eine Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! oder rufen Sie uns einfach an.

   
      Referenzen 

 Bosch 
  T-Systems
  Hagebau
  Siemens
 Areva  VW
 Haufe-Lexware  British American Tobacco
  nagel group farbe
   
     Programmierung
Excel Auftragsprogrammierung Access Auftragsprogrammierung
Word Auftragsprogrammierung Outlook Auftragsprogrammierung
   
   

Projektanfrage

 Sie benötigen eine Auftragsprogrammierung?
 Oder suchen Unterstützung bei der Lösungs-
 findung?

  Nutzen Sie unser Auftragsformular

  Jetzt anrufen unter 0151 / 164 55 914

 Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! Projektanfrage per Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! senden

  Weitere Informationen

sitepanel question2

P
r
o
j
e
k
t
a
n
f
r
a
g
e
   

Anzahl der Einträge innerhalb einer Zelle ermitteln

Die in diesem  Beispiel vorgestellte Formel zählt die mit einem Trennzeichen wie beispielsweise Komma (,) oder Semikolon (;) getrennte Einträge innerhalb einer Zelle.

1. Im ersten Beispiel befinden sich in Zelle A2 folgende Einträge: Müller, Meier, Schmid, Eckl

Tragen Sie in Zelle B2 folgende Formel ein:
=WENN(LÄNGE(GLÄTTEN(A2))=0;0;LÄNGE(GLÄTTEN(A2))-LÄNGE(WECHSELN(A2;",";""))+1)

Da als Trennzeichen in der Zelle ein Komma verwendet wurde, muss dieses entsprechend in der Formel angegeben werden, siehe rote Markierung.

Das Ergebnis lautet 4, da vier verschiedene Namen in der Zelle vorhanden sind.

2. Im zweiten Beispiel befinden sich in Zelle A2 folgende Einträge: Max; Klaus; Birgit

Um die Anzahl zu Ermitteln tragen Sie in Zelle B2 folgende, leicht veränderte Formel ein:
=WENN(LÄNGE(GLÄTTEN(A2))=0;0;LÄNGE(GLÄTTEN(A2))-LÄNGE(WECHSELN(A2;";";""))+1)

Die Einzige Änderung ist, dass als Suchkriterium für die Funktion das Semikolon (;) anstatt das Komma (,) angegeben wird. Das Ergebnis der Formel lautet 3.

3. Im Dritten Beispiel wurde kein explizites Trennzeichen verwendet, sondern es befinden sich nur Leerzeichen zwischen den Einträgen in Zelle A2: München Stuttgart Nürnberg Berlin Köln

Auch diese Art der Trennung kann mit der vorliegenden Formel problemlos verarbeitet werden. Ändern Sie dazu die Formel wie folgt ab:

=WENN(LÄNGE(GLÄTTEN(A2))=0;0;LÄNGE(GLÄTTEN(A2))-LÄNGE(WECHSELN(A2;" ";""))+1)

Mit dieser Änderung sucht die Formel nach einem Leerzeichen als Trennzeichen und liefert als Ergebnis den Wert 5 zurück.

   

Relevante Artikel

  • Automatische Aktualisierung des Datenbereiches wenn dieser erweitert wird

    207077 Möchten Sie bspw. die Zelle B5über die die Sheets "Tabelle2" bis "Tabelle5" summieren so gibt es eine elegante Möglichkeit. Tragen Sie einen Namen bspw. Daten ein und verwenden Sie die...

  • Neue Diagrammtypen in Excel 2016

    Mit dem neuen Update zu Excel 2016 Preview wurden neue Diagramm-Typen zu Excel hinzugefügt. Folgende neuen Diagramme stehen zur Verfügung: 1. Wasserfall-Diagramm (Bild: Microsoft) Mehr zum...

  • Anzahl der Undo-Schritte (Rückgängig) erhöhen

    503001 Für Excel gibt es die Möglichkeit die Anzahl der "Rückgängig" Aktionen (Undo-Schritte), wie in Word auf 100 zu erweitern. Es handelt sich dabei um einen Registry-Eintrag, der angepasst werden...

  • Excel 2013: Neue PivotTable Funktionen

    Excel 2013 bietet zwei neue Funktionen für Pivot-Tables. Mit Hilfe dieser beiden Erweiterungen lässt sich die PivotTable Funktion noch praxisorientierter verwenden. Auswertungen lassen sich damit...

  • Bezeichnung / Name des Tabellenblatts auslesen

    In vielen Situationen wird die Bezeichnung des Tabellenblattes benötigt, bspw. wenn in einer Formel Bezug auf ein anderes Tabellenblatt genommen wird. Der Blattname kann entweder über eine Formel- oder...