Brauchen Sie Hilfe?
Web:     Online-Formular
E-Mail:  
Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!
Tel:       +49(0)151 / 164 55 914

Nutzen Sie für Ihre Anfrage unser Online-Formular oder senden Sie uns eine E-Mail an Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!. Gerne können Sie aber auch direkt telefonisch Kontakt aufnehmen.

   
     Referenzen
 Bosch 
  T-Systems
  Hagebau
  Siemens
 Areva  VW
 Haufe-Lexware  British American Tobacco
  nagel group farbe
   

Anzahl der Einträge innerhalb einer Zelle ermitteln

Die in diesem  Beispiel vorgestellte Formel zählt die mit einem Trennzeichen wie beispielsweise Komma (,) oder Semikolon (;) getrennte Einträge innerhalb einer Zelle.

1. Im ersten Beispiel befinden sich in Zelle A2 folgende Einträge: Müller, Meier, Schmid, Eckl

Tragen Sie in Zelle B2 folgende Formel ein:
=WENN(LÄNGE(GLÄTTEN(A2))=0;0;LÄNGE(GLÄTTEN(A2))-LÄNGE(WECHSELN(A2;",";""))+1)

Da als Trennzeichen in der Zelle ein Komma verwendet wurde, muss dieses entsprechend in der Formel angegeben werden, siehe rote Markierung.

Das Ergebnis lautet 4, da vier verschiedene Namen in der Zelle vorhanden sind.

2. Im zweiten Beispiel befinden sich in Zelle A2 folgende Einträge: Max; Klaus; Birgit

Um die Anzahl zu Ermitteln tragen Sie in Zelle B2 folgende, leicht veränderte Formel ein:
=WENN(LÄNGE(GLÄTTEN(A2))=0;0;LÄNGE(GLÄTTEN(A2))-LÄNGE(WECHSELN(A2;";";""))+1)

Die Einzige Änderung ist, dass als Suchkriterium für die Funktion das Semikolon (;) anstatt das Komma (,) angegeben wird. Das Ergebnis der Formel lautet 3.

3. Im Dritten Beispiel wurde kein explizites Trennzeichen verwendet, sondern es befinden sich nur Leerzeichen zwischen den Einträgen in Zelle A2: München Stuttgart Nürnberg Berlin Köln

Auch diese Art der Trennung kann mit der vorliegenden Formel problemlos verarbeitet werden. Ändern Sie dazu die Formel wie folgt ab:

=WENN(LÄNGE(GLÄTTEN(A2))=0;0;LÄNGE(GLÄTTEN(A2))-LÄNGE(WECHSELN(A2;" ";""))+1)

Mit dieser Änderung sucht die Formel nach einem Leerzeichen als Trennzeichen und liefert als Ergebnis den Wert 5 zurück.

   

Relevante Artikel

  • Wochenenden farbig markieren

    207065 Im Bereich A1:A20 steht eine Datumsreihe. Über den Befehl Bedingte Formatierung werden  nun die Wochenenden farbig hervorgehoben. Dazu gehen Sie wie folgt vor: 1. Markieren Sie den Bereich...

  • Alle Excel Startparameter

    500003 Excel hat verschiedene Startparamter. Nachfolgende Liste zeigt alle Startparamter auf und gibt eine kleine Erläuterung dazu. Erstellen Sie zuerst eine Verknüpfung zu Excel z. B. auf dem...

  • Neue Symbolleisten in Excle 2010 - Interaktives Handbuch

    Möchten Sie wissen, wo sich die am häufigsten verwendeten Menü- und Symbolleistenbefehle in Office 2010 befinden? Dann sind Sie hier richtig. Microsoft stellt interaktive Handbücherfür die...

  • SUMMEWENN mit Textfragmenten

    Mit Hilfe der Funktion SUMMEWENN() werden in einem Bereich nur die Werte summiert, die mit dem Suchkriterium übereinstimmen. Mit =SUMMEWENN(A1:A50;">20";B1:B50") wird im Bereich A1:A50 geprüft, ob der...

  • Bezug der Summenformel soll erhalten bleiben

      207051     A B C 1 10 =SUMME(A1:A5) =SUMME(INDIREKT("A1"):INDIREKT("A5")) 2 10     3 10     4 10     5 10       Wird nach der Zeile 3 eine neue Zeile eingefügt, passiert folgendes: Variante in Zelle B1: Der Summenbereich erweitert...

   

Excel-Inside auf Facebook Excel-Live News blog Excel-Inside RSS-Feed Twitter Account für Excel-Inside Mail an Excel-Inside 

Programmierung
Excel Auftragsprogrammierung Access Auftragsprogrammierung
Word Auftragsprogrammierung Outlook Auftragsprogrammierung
   
Unsere Produkte
Office Schulungen VBA, Excel, Access
E-Book Formeln und Funktionen Excel 2013