Anzahl der Einträge innerhalb einer Zelle ermitteln

Die in diesem  Beispiel vorgestellte Formel zählt die mit einem Trennzeichen wie beispielsweise Komma (,) oder Semikolon (;) getrennte Einträge innerhalb einer Zelle.

1. Im ersten Beispiel befinden sich in Zelle A2 folgende Einträge: Müller, Meier, Schmid, Eckl

Tragen Sie in Zelle B2 folgende Formel ein:
=WENN(LÄNGE(GLÄTTEN(A2))=0;0;LÄNGE(GLÄTTEN(A2))-LÄNGE(WECHSELN(A2;",";""))+1)

Da als Trennzeichen in der Zelle ein Komma verwendet wurde, muss dieses entsprechend in der Formel angegeben werden, siehe rote Markierung.

Das Ergebnis lautet 4, da vier verschiedene Namen in der Zelle vorhanden sind.

2. Im zweiten Beispiel befinden sich in Zelle A2 folgende Einträge: Max; Klaus; Birgit

Um die Anzahl zu Ermitteln tragen Sie in Zelle B2 folgende, leicht veränderte Formel ein:
=WENN(LÄNGE(GLÄTTEN(A2))=0;0;LÄNGE(GLÄTTEN(A2))-LÄNGE(WECHSELN(A2;";";""))+1)

Die Einzige Änderung ist, dass als Suchkriterium für die Funktion das Semikolon (;) anstatt das Komma (,) angegeben wird. Das Ergebnis der Formel lautet 3.

3. Im Dritten Beispiel wurde kein explizites Trennzeichen verwendet, sondern es befinden sich nur Leerzeichen zwischen den Einträgen in Zelle A2: München Stuttgart Nürnberg Berlin Köln

Auch diese Art der Trennung kann mit der vorliegenden Formel problemlos verarbeitet werden. Ändern Sie dazu die Formel wie folgt ab:

=WENN(LÄNGE(GLÄTTEN(A2))=0;0;LÄNGE(GLÄTTEN(A2))-LÄNGE(WECHSELN(A2;" ";""))+1)

Mit dieser Änderung sucht die Formel nach einem Leerzeichen als Trennzeichen und liefert als Ergebnis den Wert 5 zurück.

   

Excel-Inside auf FacebookExcel-Live News blogExcel-Inside RSS-FeedMail an Excel-InsideTwitter Account für Excel-InsideMail an Excel-Inside

Office Programmierung

Excel Auftragsprogrammierung

Access Auftragsprogrammierung

Word Auftragsprogrammierung

Outlook Auftragsprogrammierung

 

 

 

 




   
Office Schulungen VBA, Excel, Access
E-Book Formeln und Funktionen Excel 2013
Excel-Inside Newsletter abonnieren
   

Backlink  

ERROR: PAGE_URL belons not to given domain: 573001800