Projektanfrage

Projektanfrage über Web Formular   per Online-Formular 
Projektanfrage über E-Mail  Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!
Projektanfrage per Telefon  +49 (0)151 / 164 55 914
Projektanfrage weitere Informationen  weitere Informationen 

Sie benötigen Hilfe oder Unter-stützung? Nutzen Sie für Ihre Anfrage unser Online-Formular, senden Sie uns eine Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! oder rufen Sie uns einfach an.

   
      Referenzen 

 Bosch 
  T-Systems
  Hagebau
  Siemens
 Areva  VW
 Haufe-Lexware  British American Tobacco
  nagel group farbe
   
     Programmierung
Excel Auftragsprogrammierung Access Auftragsprogrammierung
Word Auftragsprogrammierung Outlook Auftragsprogrammierung
   
   

Projektanfrage

 Sie benötigen eine Auftragsprogrammierung?
 Oder suchen Unterstützung bei der Lösungs-
 findung?

  Nutzen Sie unser Anfrageformular

  Jetzt anrufen unter 0151 / 164 55 914

 Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! Projektanfrage per Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! senden

  Weitere Informationen

sitepanel question2

P
R
O
J
E
K
T
A
N
F
R
A
G
E
   

Anzahl der Einträge innerhalb einer Zelle ermitteln

Die in diesem  Beispiel vorgestellte Formel zählt die mit einem Trennzeichen wie beispielsweise Komma (,) oder Semikolon (;) getrennte Einträge innerhalb einer Zelle.

1. Im ersten Beispiel befinden sich in Zelle A2 folgende Einträge: Müller, Meier, Schmid, Eckl

Tragen Sie in Zelle B2 folgende Formel ein:
=WENN(LÄNGE(GLÄTTEN(A2))=0;0;LÄNGE(GLÄTTEN(A2))-LÄNGE(WECHSELN(A2;",";""))+1)

Da als Trennzeichen in der Zelle ein Komma verwendet wurde, muss dieses entsprechend in der Formel angegeben werden, siehe rote Markierung.

Das Ergebnis lautet 4, da vier verschiedene Namen in der Zelle vorhanden sind.

2. Im zweiten Beispiel befinden sich in Zelle A2 folgende Einträge: Max; Klaus; Birgit

Um die Anzahl zu Ermitteln tragen Sie in Zelle B2 folgende, leicht veränderte Formel ein:
=WENN(LÄNGE(GLÄTTEN(A2))=0;0;LÄNGE(GLÄTTEN(A2))-LÄNGE(WECHSELN(A2;";";""))+1)

Die Einzige Änderung ist, dass als Suchkriterium für die Funktion das Semikolon (;) anstatt das Komma (,) angegeben wird. Das Ergebnis der Formel lautet 3.

3. Im Dritten Beispiel wurde kein explizites Trennzeichen verwendet, sondern es befinden sich nur Leerzeichen zwischen den Einträgen in Zelle A2: München Stuttgart Nürnberg Berlin Köln

Auch diese Art der Trennung kann mit der vorliegenden Formel problemlos verarbeitet werden. Ändern Sie dazu die Formel wie folgt ab:

=WENN(LÄNGE(GLÄTTEN(A2))=0;0;LÄNGE(GLÄTTEN(A2))-LÄNGE(WECHSELN(A2;" ";""))+1)

Mit dieser Änderung sucht die Formel nach einem Leerzeichen als Trennzeichen und liefert als Ergebnis den Wert 5 zurück.

   

Relevante Artikel

  • Excel 2007 Produktivitäts-Tipps

    Der folgende Beitrag zeigt eine Reihe von Produktivitäts-Tipps uns Tricks für Excel 2007.   Ein- und Ausblenden der Zwischenablage-Task-Pane   Excel bietet eine Funktion, um die Zwischenablage Ein- und...

  • Unikate aus Liste extrahieren

    In diesem Beispiel liegt eine Liste vor, die einen Eintrag jeweils mehrfach enthält. Ziel ist nun, aus der Liste jeden der mehrfach vorkommenden Werte jeweils nur ein einziges mal auszulesen und in...

  • Monats- bzw. Jahreswerte um den Wert 1 erhöhen

    201001 Die Funktion Datum () + X Monate liefert ausgehend von einem Monatsletzten falsche Ergebnisse, da sich ein Bug in Excel befindet. Die Rechnung Datum() + 30 ergibt ebenfalls das falsche...

  • Berechnungen ohne Istgleich-Zeichen durchführen

    207003 Möchten Sie z. B. Zahlen berechnen, die in der Zelle A1 ohne führendes Istgleich-Zeichen eingegeben sind? Über die Funktion "Namen definieren" können Sie diese Zahlen berechnen. Geben Sie...

  • Excel 2013: Bing Maps in Excel verwenden

    Bei Bing Maps handelt es sich um eine App aus dem Office App Store. Um Bing Maps verwenden zu können, muss diese also zunächst aus dem App Store geladen werden. Eine Beschreibung findest Du im...

   
Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Bestätigung erklären Sie sich mit der Verwendung von Cookies auf Excel-Inside Solutions einverstanden.
Weitere Informationen Ok