Projektanfrage

Projektanfrage über Web Formular   per Online-Formular 
Projektanfrage über E-Mail  Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!
Projektanfrage per Telefon  +49 (0)151 / 164 55 914
Projektanfrage weitere Informationen  weitere Informationen 

Sie benötigen Hilfe oder Unter-stützung? Nutzen Sie für Ihre Anfrage unser Online-Formular, senden Sie uns eine Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! oder rufen Sie uns einfach an.

   
      Referenzen 

 Bosch 
  T-Systems
  Hagebau
  Siemens
 Areva  VW
 Haufe-Lexware  British American Tobacco
  nagel group farbe
   
     Programmierung
Excel Auftragsprogrammierung Access Auftragsprogrammierung
Word Auftragsprogrammierung Outlook Auftragsprogrammierung
   
   

Projektanfrage

 Sie benötigen eine Auftragsprogrammierung?
 Oder suchen Unterstützung bei der Lösungs-
 findung?

  Nutzen Sie unser Anfrageformular

  Jetzt anrufen unter 0151 / 164 55 914

 Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! Projektanfrage per Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! senden

  Weitere Informationen

sitepanel question2

P
r
o
j
e
k
t
a
n
f
r
a
g
e
   

Variablen Bereichsnamen dynamisch erzeugen - Dropdown-Menüs

Bereichsnamen werden typischerweise verwendet, um einem definierten Zellbereich z. B. A1:B20 einen Namen zuzuweisen, über den dieser Bereich angesprochen werden kann. Der Befehl zur Erstellung von Bereichsnamen wird über das Menü Formeln / Definierte Namen / Namen definieren / Namen definieren aufgerufen. In diesem Beitrag möchten wir Ihnen eine Möglichkeit zeigen, wie einem bestimmten Bereichsnamen dynamisch unterschiedliche Zellen zugewiesen werden können.

Im Beispiel liegt eine Mitarbeitertabelle getrennt nach Niederlassungen vor, siehe Abbildung 1.


Abbildung 1

In Zelle C4 befindet sich ein DropDown-Menü (Datengültigkeit), über das zwischen den vier Niederlassungen gewählt werden kann, siehe Abbildung 2.


Abbildung 2

Ziel soll nun sein, dass nach Auswahl einer Niederlassung die entsprechenden Mitarbeiter in dem DropDown-Auswahlfeld in Zelle C5 zur Verfügung stehen und ausgewählt werden können. So sollen beispielsweise bei Auswahl der Niederlassung Köln die Mitarbeiter Monsens, Niesel, Persich und Reiser als Auswahl zur Verfügung stehen.

Dazu wird ein Bereichsname mit der Bezeichnung Mitarbeiter definiert. Als Zellbezug muss folgende Formel verwendet werden, siehe auch Abbildung 3.

=WENN('Dynamische Bereichsnamen'!C4="München";'Dynamische Bereichsnamen'!F5:F8;WENN('Dynamische Bereichsnamen'!C4="Hamburg";'Dynamische Bereichsnamen'!G5:G8;WENN('Dynamische Bereichsnamen'!C4="Köln";'Dynamische Bereichsnamen'!H5:H8;WENN('Dynamische Bereichsnamen'!C4="Berlin";'Dynamische Bereichsnamen'!I5:I8;""))))


Abbildung 3

Diese Formel prüft, welche Niederlassung in Zelle C4 ausgewählt wurde und weist dann dem Bereichsnamen Mitarbeiter den entsprechenden Zellbereich zu. Bei München wird der Zellbereich F5:F8 zugewiesen, bei Auswahl von Hamburg entsprechend der Zellbereich H5:H8 und so weiter.

Sobald nun eine andere Niederlassung in Zelle C4 ausgewählt wird, wird die Auswahlliste in Zelle C5 dynamisch aktualisiert.

Über den folgenden Link können Sie die Beispieldatei herunterladen.

 

Eine weitere Möglichkeit der Datenauswahl kann über die Funktion SVERWEIS() durchgeführt werden. Damit entfallen umfangreiche WENN-Verschachtelungen.

Erfassen Sie dazu anstatt der WENN-Formel folgende Formel beim Bereichsnamen "Mitarbeiter".

=INDIREKT(WVERWEIS('Dynamische Bereichsnamen'!$C$4;'Dynamische Bereichsnamen'!$F$4:$I$9;2;0))

Diese Formel liefert das gleiche Ergebnis, ist jedoch für umfangreichere Datentabellen leichter anzupassen. Die Lösung können sie über den folgenden Link herunterladen.

   

Relevante Artikel

  • Datum Autoausfüllen nur für Wochentage (ohne Wochenende)

    In diesem Beispiel zeigen wir Ihnen, wie Sie ganz einfach eine Liste von Wochentagen erzeugen können. Die Wochenenden werden dabei in der Liste unterdrückt.Dies können Sie auf zwei verschiedenen...

  • SVERWEIS mit erweiterter Suchfunktion

    SVERWEIS() wird häufig eingesetzt, um Daten aus einer Matrix anhand eines Suchkriteriums auszulesen. Dabei wird in der Regel ein eindeutiges Suchkriterium wie beispielsweise eine eindeutige...

  • Den ersten Eintrag einer alphabetisch sortierten Liste markieren

    In einem alphabetisch sortierten Inhaltsverzeichnis (Liste) soll der erste Eintrag einer neuen Buchstabengruppe gekennzeichnet werden. Dazu soll der erste Eintrag mit blauer Schriftfarbe...

  • Immer die gleiche Zeile aus gefilterter Liste auslesen

    Dieses Beispiel zeigt, wie immer die gleiche Zeile aus einer gefilterten Liste ausgelesen werden kann, gleichgültig wie der Filter gesetzt wird. Als Grundlage dient eine Artikelliste, siehe...

  • SUMMEWENN mit Textfragmenten

    Mit Hilfe der Funktion SUMMEWENN() werden in einem Bereich nur die Werte summiert, die mit dem Suchkriterium übereinstimmen. Mit =SUMMEWENN(A1:A50;">20";B1:B50") wird im Bereich A1:A50 geprüft, ob der...