Erzeugung von dynamischen Zeit- und Datums-Reihen

In diesem Beispiel zeigen wir Ihnen, wie ausgehend von einem Start-Wert und einem End-Wert eine entsprechende Zeit- und Datumsplanung vollautomatisch erzeugt werden kann.

Beispiel 1: Dynamische Datumsreihe

Das erste Beispiel zeigt ein fortlaufendes Datum zwischen dem 01.06.2013 und dem 30.05.2015, das zwischen dem Start- und dem End-Datum dynamisch in die Tabelle eingetragen wird, siehe Abbildung.

Zur Erzeugung des ersten Datums in Zelle G9 wird folgende Formel verwendet: =ZEILE(INDIREKT(H3&":"&H4))

Markieren Sie anschließend den Zellbereich G9 bis G374 und Beenden Sie die Formeleingabe mit der Tastenkombination [Strg] + [Umschalt] + [Enter]. Damit wird eine Matrixformel erzeugt, die in den kompletten markierten Bereich eingetragen wird. Sobald Sie nun das Start- oder Ende-Datum verändern wird das Datumsraster entsprechend angepasst. Die folgende Abbildung zeigt die Planung mit geänderten Start- und Endterminen.

Sie sehen, dass die Auflistung nur bis zum eingegebenen Endtermin am 10.04.2013 fortgeführt wird. 

Mit Hilfe der Bedingten Formatierung wird verhindert, dass am dem 11.04.2013 keine Fehlermeldung angezeigt wird. Mit Hilfe einer Regel wird einfach die Schriftfarbe auf weiß gesetzt, sobald der Fehlerwert #NV ausgegeben wird. Die folgende Abbildung zeigt die Einstellung für die Bedingte Formatierung.

 

Beispiel 2: Dynamische Zeitreihe

Im zweiten Beispiel sehen Sie, wie sich auf ähnliche Art und Weise eine dynamische Zeitreihe aufbauen lässt. Diese Zeitreihe hat noch eine Besonderheit. Über ein DropDown-Feld lässt sich das Zeitraster einstellen. So kann in Zelle C5 zwischen 15, 30 und 60 Minuten gewählt werden. Das dynamische Zeitraster wird ebenso wie bei Datumsraster über eine Formel erzeugt. Erfassen Sie dazu folgende Formel in Zelle B9: =ZEILE(INDIREKT(C3*C6*24&":"&C4*C6*24))/24/C6

Markieren Sie den Zellbereich B9 bis B104 und beenden Sie die Eingabe mit der Tastenkombination [Strg] + [Umschalt] + [Enter]. Damit wird eine Matrixformel erzeugt und die Formel in den markierten Zellbereich eingetragen, siehe Abbildung.

Wenn nun das Raster in Zelle C5 auf beispielsweise  15 Minuten einstellen, ergibt sich folgendes Bild.

Zur Realisierung der Intervalleinstellung wird in Zelle C6 eine Hilfsformel verwendet: =WENN(C5=15;4;WENN(C5=30;2;1))

Fehler werden ebenso wie bei der dynamischen Datumserzeugung über die bedingte Formatierung realisert, siehe oben.

Die Beispieldatei kann unter dem folgenden Link heruntergeladen werden.

   

Excel-Inside auf FacebookExcel-Live News blogExcel-Inside RSS-FeedMail an Excel-InsideTwitter Account für Excel-InsideMail an Excel-Inside

Office Programmierung

Excel Auftragsprogrammierung

Access Auftragsprogrammierung

Word Auftragsprogrammierung

Outlook Auftragsprogrammierung

 

 

 

 




   
Office Schulungen VBA, Excel, Access
E-Book Formeln und Funktionen Excel 2013
Excel-Inside Newsletter abonnieren
   

Backlink  

ERROR: PAGE_URL belons not to given domain: 573001800