Brauchen Sie Hilfe?
Web:     Online-Formular
E-Mail:  
Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!
Tel:       +49(0)151 / 164 55 914

Nutzen Sie für Ihre Anfrage unser Online-Formular oder senden Sie uns eine E-Mail an Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!. Gerne können Sie aber auch direkt telefonisch Kontakt aufnehmen.

   
     Referenzen
 Bosch 
  T-Systems
  Hagebau
  Siemens
 Areva  VW
 Haufe-Lexware  British American Tobacco
  nagel group farbe
   

Anzahl der verschiedenen Werte einer Liste ermitteln

207054



Mit der folgenden Formel kann die Anzahl der unterschiedlichen Werte innerhalb
einer angegebenen Matrix ermittelt werden.

Wenn dabei eine Zahl >0 erreicht wird, wird der Funktion Summe der Wert 1 übergeben,
ansonsten 0.

Im Beispiel soll im Bereich A1:A20 die Anzahl der verschiedenen Werte berechnet werden. Verwenden Sie dazu folgende Formel in Zelle A12: =SUMME(WENN(HÄUFIGKEIT(A1:A10;A1:A10)>0;1))


Das Ergebnis hier lautet 5: Die Zahlen 1,2,3,4,5 sind einmal oder häufiger in dem angegebenen Bereich enthalten.
 

  A
1 1
2 2
3 3
4 4
5 5
6 1
7 5
8 4
9 3
10 2
11  
12 =SUMME(WENN(HÄUFIGKEIT(A1:A10;A1:A10)>0;1))


Hinweis: Die Formel funktioniert nur bei Zahlen, nicht bei Buchstaben.

 

   

Relevante Artikel

  • Anzahl der verschiedenen Werte einer Liste ermitteln

    207054 Mit der folgenden Formel kann die Anzahl der unterschiedlichen Werte innerhalb einer angegebenen Matrix ermittelt werden. Wenn dabei eine Zahl >0 erreicht wird, wird der Funktion Summe der Wert...

  • Zellen ohne Schutz markieren

    In Excel ist auf den ersten Blick nicht ersichtlich, welche Zellen geschützt und welche ungeschützt sind.  Die nachfolgend vorgestellte Lösung hebt mit Hilfe der bedingte Formatierung alle Zellen, bei...

  • Summierung abhängig vom Datum

    201004 Mit der nachfolgenden Funktion werden die Werte in Spalte B1 bis B15 addiert, wenn das das Datum aus Spalte A1 bis A15 im Monat Februar liegt. Beispiel:   A B C 1 01.01.2003 5   2 01.01.2003 1   3...

  • Excel 2013: Neue Formeln und Funktionen in Excel

    Wie in jeder neuen Excel-Version gibt es auch in Excel 2013 neue Formeln und Funktionen. In diesem Beitrag stelle ich euch die aus meiner Sicht wichtigsten Formeln vor. Da die Preview-Version nur in...

  • Dynamische Verknüfpung zu einem Excel Diagramm herstellen

      In diesem Beitrag zeigen wir Ihnen, wie Sie zu einem bestehenden Excel-Diagramm dynamische Verknüpfungen erzeugen können. Das verknüpfte Excel-Diagramm liegt damit als Grafik vor. Alle Änderungen...

   

Excel-Inside auf Facebook Excel-Live News blog Excel-Inside RSS-Feed Twitter Account für Excel-Inside Mail an Excel-Inside 

Programmierung
Excel Auftragsprogrammierung Access Auftragsprogrammierung
Word Auftragsprogrammierung Outlook Auftragsprogrammierung
   
Unsere Produkte
Office Schulungen VBA, Excel, Access
E-Book Formeln und Funktionen Excel 2013