Projektanfrage

Projektanfrage über Web Formular   per Online-Formular 
Projektanfrage über E-Mail  Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!
Projektanfrage per Telefon  +49 (0)151 / 164 55 914
Projektanfrage weitere Informationen  weitere Informationen 

Sie benötigen Hilfe oder Unter-stützung? Nutzen Sie für Ihre Anfrage unser Online-Formular, senden Sie uns eine Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! oder rufen Sie uns einfach an.

   
      Referenzen 

 Bosch 
  T-Systems
  Hagebau
  Siemens
 Areva  VW
 Haufe-Lexware  British American Tobacco
  nagel group farbe
   
     Programmierung
Excel Auftragsprogrammierung Access Auftragsprogrammierung
Word Auftragsprogrammierung Outlook Auftragsprogrammierung
   

Projektanfrage

 Sie benötigen eine Auftragsprogrammierung?
 Oder suchen Unterstützung bei der Lösungs-
 findung?

  Nutzen Sie unser Anfrageformular

  Jetzt anrufen unter 0151 / 164 55 914

 Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! Projektanfrage per Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! senden

  Weitere Informationen

sitepanel question2

P
R
O
J
E
K
T
A
N
F
R
A
G
E
   

Monats- bzw. Jahreswerte um den Wert 1 erhöhen

201001



Die Funktion Datum () + X Monate liefert ausgehend von einem Monatsletzten falsche Ergebnisse, da sich ein Bug in Excel befindet. Die Rechnung Datum() + 30 ergibt ebenfalls das falsche Ergebnis, da die Monate eine unterschiedliche Anzahl von Tagen haben.

 

Die Funktion =DATUM(JAHR(A1);MONAT(A1)+2;TAG(A1))

führt zu folgendem Ergebnis (Spalte C) 

A

B

C D
3 Datum  + Anzahl Mte. Ergebnis Richtig
4 31.12.2000 2 03.03.2001 28.02.2001
5 28.02.2001 2 28.04.2001 30.04.2001


Die folgende Lösung behebt den Fehler, der durch ungleich lange Monate im Monatsendbereich entsteht
.
 

Lösung

das Datum steht in A1

die zu addierenden Jahre in A2

die zu addierenden Monate in A3


in B1 (B ist Hilfsspalte) steht
=DATUM(JAHR(A1)+A2;MONAT(A1)+A3;TAG(A1))


in B2 steht

=WENN(UND(MONAT(A1+1)>MONAT(A1);MONAT(B1+1)=MONAT(B1));1;0)


das Enddatum in C1 lautet dann:

=DATUM(JAHR(A1)+A2;MONAT(A1)+B2+A3;WENN(B2=1;0;TAG(A1)-WENN(TAG(A1)>TAG(B1);TAG(B1);0)))

Wer sich die Hilfsspalte sparen will, schreibt halt alles in einer Formel in C1:

=DATUM(JAHR(A1)+A2;MONAT(A1)+WENN(UND(MONAT(A1+1)>MONAT(A1);MONAT(B1+1)=MONAT(B1));1;0)
+A3;WENN(WENN(UND(MONAT(A1+1)>MONAT(A1);MONAT(B1+1)=MONAT(B1));1;0)=1;0;TAG(A1)-WENN(TAG(A1)>TAG(DATUM(JAHR(A1)+A2;MONAT(A1)+A3;TAG(A1)));TAG(DATUM(JAHR(A1)+A2;MONAT(A1)
+A3;TAG(A1)));0)))


 

   

Relevante Artikel

  • SVERWEIS mit erweiterter Suchfunktion

    SVERWEIS() wird häufig eingesetzt, um Daten aus einer Matrix anhand eines Suchkriteriums auszulesen. Dabei wird in der Regel ein eindeutiges Suchkriterium wie beispielsweise eine eindeutige...

  • Nummerierung, wenn in Nachbarzelle ein Wert steht

    207001 In der Spalte A soll hochgezaehlt werden, wenn in Spalte B in der gleichen Zeile eine Wert steht (Zahl, Text, Datum etc.). Befindet sich in Spalte B kein Wert, soll diese Zeile nicht...

  • Zeilen in 3er-Schritten nummerieren

    Sie möchten z. B. die Spalte A in 3er-Schritten nummerieren? Dann tragen Sie folgende Formel in Zelle A1 bzw. in die gewünschte Startzelle ein. =WENN(REST(ZEILE();3)=0;ZEILE();"") Kopieren Sie die...

  • Text mit formatierem Datum oder formatierter Zahl verknüpfen

    Um das Datum aus Zelle A1 mit einem Text zu verknüpfen ist die Funktion Text notwendig. Der Funktion Text kann zusätzlich zum Wert ein Textformat übergeben werden. Die Funktion Text hat also...

  • dynamsiches Diagramm

    In diesem Beitrag zeigen wir Ihnen, wie sich Diagramme mit dynamischen Datenbereichenerzeugen lassen. Das bedeutet, wenn die Datenliste, also die Datenquelle für das Diagramm erweitert wird, soll die...

   
Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Bestätigung erklären Sie sich mit der Verwendung von Cookies auf Excel-Inside Solutions einverstanden.
Weitere Informationen Ok