Projektanfrage

Projektanfrage über Web Formular   per Online-Formular 
Projektanfrage über E-Mail  Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!
Projektanfrage per Telefon  +49 (0)151 / 164 55 914
Projektanfrage weitere Informationen  weitere Informationen 

Sie benötigen Hilfe oder Unter-stützung? Nutzen Sie für Ihre Anfrage unser Online-Formular, senden Sie uns eine Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! oder rufen Sie uns einfach an.

   
      Referenzen 

 Bosch 
  T-Systems
  Hagebau
  Siemens
 Areva  VW
 Haufe-Lexware  British American Tobacco
  nagel group farbe
   
     Programmierung
Excel Auftragsprogrammierung Access Auftragsprogrammierung
Word Auftragsprogrammierung Outlook Auftragsprogrammierung
   
   

Projektanfrage

 Sie benötigen eine Auftragsprogrammierung?
 Oder suchen Unterstützung bei der Lösungs-
 findung?

  Nutzen Sie unser Auftragsformular

  Jetzt anrufen unter 0151 / 164 55 914

 Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! Projektanfrage per Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! senden

  Weitere Informationen

sitepanel question2

P
r
o
j
e
k
t
a
n
f
r
a
g
e
   

Nachgestelltes Minus nach Import korrigieren

207074



Nach einem Textimport werden die Vorzeichen von Zahlen nicht immer richtig dargestellt.
Oft wird das Minus-Zeichen hinter die Zahl gestellt. Mit solch einer Zahlendarstellung kann Excel
nicht umgehen und somit natürlich nicht weiterrechnen.

Mit einer Funktion lässt sich das Problem jedoch leicht lösen.
Das hinten angestellte Minus wird einfach abgeschnitten und vor die Zahl gesetzt.

Die Funktion dazu lautet:

=WENN(RECHTS(A3;1)="-";WERT("-"&LINKS(A3;LÄNGE(A3)-1));A3)

Das folgende Beispiel soll das ganze noch einmal verdeutlichen!
A B C
1 Zahlen vor Zahlen nach
2 Korrektur Korrektur
3

15,5

15,5 =WENN(RECHTS(A3;1)="-";WERT("-"&LINKS(A3;LÄNGE(A3)-1));A3)
4

13

13 =WENN(RECHTS(A4;1)="-";WERT("-"&LINKS(A4;LÄNGE(A4)-1));A4)
5 -12,3 -12,3 =WENN(RECHTS(A5;1)="-";WERT("-"&LINKS(A5;LÄNGE(A5)-1));A5)
6 23,56- -23,56 =WENN(RECHTS(A6;1)="-";WERT("-"&LINKS(A6;LÄNGE(A6)-1));A6)
7 17,5- -17,5 =WENN(RECHTS(A7;1)="-";WERT("-"&LINKS(A7;LÄNGE(A7)-1));A7)
8 -22 -22 =WENN(RECHTS(A8;1)="-";WERT("-"&LINKS(A8;LÄNGE(A8)-1));A8)
9 21- -21 =WENN(RECHTS(A9;1)="-";WERT("-"&LINKS(A9;LÄNGE(A9)-1));A9)
10

1,55

1,55 =WENN(RECHTS(A10;1)="-";WERT("-"&LINKS(A10;LÄNGE(A10)-1));A10)
11 55,55- -55,55 =WENN(RECHTS(A11;1)="-";WERT("-"&LINKS(A11;LÄNGE(A11)-1));A11)

Sie müssen nur die Formel in die Zelle C3 eintragen und mit dem Autoausfüllkästchen nach unten ziehen.


 

   

Relevante Artikel

  • SVERWEIS versus INDEX / VERGLEICH

    In diesem Beitrag vergleichen wir die beiden Möglichkeiten Daten in einer Liste zu suchen und das Ergebnis auszugeben.   Der von Excel vorgesehene Befehl lautet SVERWEIS(). Die allgemeine Syntax...

  • Dateneingabe mittels (Daten-)Maske

    Dieser Tipp zeigt, wie strukturierte Daten ganz einfach und trotzdem komfortabel mit Hilfe der integrierten Dateneingabe-Maskein ein Excel-Tabellenblatt eintragen werden können. Als Beispiel dient...

  • Wiederverwendbare Diagrammvorlage

    In umfangreichen Berichten sollen alle Diagramme häufig gleich formatiert sein. Excel bietet Ihnen dazu die Möglichkeit an, ein individuelles Diagramm als Diagrammvorlage abzuspeichern.. Sie müssen...

  • Zeiten ohne Doppelpunkt erfassen

    Wenn Sie häufig Zeiten in Excel erfassen, dann kommt Ihnen dieser Tipp vielleicht gelegen. Normalerweise wird eine Zeitangabe in Excel mit einem Doppelpunkt zwischen Stunden- und Minutenangabe...

  • Prüfen, ob ein bestimmter Wert in einer Liste vorkommt

    207060 Im Bereich A1:A5 steht eine Liste von Namen. In B1 steht der Wert, der überprüft werden soll, ob er in der Matrix A1:A5 vorhanden ist.   A B 1 Hans Alois 2 Alois   3 Christine   4 Werner   5 Wigbert...