Brauchen Sie Hilfe?
Web:     Online-Formular
E-Mail:  
Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!
Tel:       +49(0)151 / 164 55 914

Nutzen Sie für Ihre Anfrage unser Online-Formular oder senden Sie uns eine E-Mail an Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!. Gerne können Sie aber auch direkt telefonisch Kontakt aufnehmen.

   
     Referenzen
 Bosch 
  T-Systems
  Hagebau
  Siemens
 Areva  VW
 Haufe-Lexware  British American Tobacco
  nagel group farbe
   

Nachgestelltes Minus nach Import korrigieren

207074



Nach einem Textimport werden die Vorzeichen von Zahlen nicht immer richtig dargestellt.
Oft wird das Minus-Zeichen hinter die Zahl gestellt. Mit solch einer Zahlendarstellung kann Excel
nicht umgehen und somit natürlich nicht weiterrechnen.

Mit einer Funktion lässt sich das Problem jedoch leicht lösen.
Das hinten angestellte Minus wird einfach abgeschnitten und vor die Zahl gesetzt.

Die Funktion dazu lautet:

=WENN(RECHTS(A3;1)="-";WERT("-"&LINKS(A3;LÄNGE(A3)-1));A3)

Das folgende Beispiel soll das ganze noch einmal verdeutlichen!
A B C
1 Zahlen vor Zahlen nach
2 Korrektur Korrektur
3

15,5

15,5 =WENN(RECHTS(A3;1)="-";WERT("-"&LINKS(A3;LÄNGE(A3)-1));A3)
4

13

13 =WENN(RECHTS(A4;1)="-";WERT("-"&LINKS(A4;LÄNGE(A4)-1));A4)
5 -12,3 -12,3 =WENN(RECHTS(A5;1)="-";WERT("-"&LINKS(A5;LÄNGE(A5)-1));A5)
6 23,56- -23,56 =WENN(RECHTS(A6;1)="-";WERT("-"&LINKS(A6;LÄNGE(A6)-1));A6)
7 17,5- -17,5 =WENN(RECHTS(A7;1)="-";WERT("-"&LINKS(A7;LÄNGE(A7)-1));A7)
8 -22 -22 =WENN(RECHTS(A8;1)="-";WERT("-"&LINKS(A8;LÄNGE(A8)-1));A8)
9 21- -21 =WENN(RECHTS(A9;1)="-";WERT("-"&LINKS(A9;LÄNGE(A9)-1));A9)
10

1,55

1,55 =WENN(RECHTS(A10;1)="-";WERT("-"&LINKS(A10;LÄNGE(A10)-1));A10)
11 55,55- -55,55 =WENN(RECHTS(A11;1)="-";WERT("-"&LINKS(A11;LÄNGE(A11)-1));A11)

Sie müssen nur die Formel in die Zelle C3 eintragen und mit dem Autoausfüllkästchen nach unten ziehen.


 

   

Relevante Artikel

  • Rechnen mit Uhrzeiten über die 0-Uhr-Grenze hinaus

    201003     Möchten Sie mit Uhrzeiten Rechnen. Kein Problem! Excel unterstützt das Rechnen mit Uhrzeiten. Schwierig ist es jedoch mit Uhrzeiten zu rechnen, wenn diese über die 0 Uhr-Grenze hinaus...

  • Cursor- und Zellzeiger-Animation in Office 2013 deaktivieren

    Für viele Anwender ist die neue Annimation des Cursors in Word und des Zellzeigers in Excel ein netter Gimick. Einige werden sich jedoch die altbekannt und bewährte Optik zurückwünschen. Kein...

  • Excel 2013: Spreadsheet Compare – Tabellen vergleichen

    Office 2013 bietet ein Tool mit der Bezeichnung Spreadsheet Compare. Dieses Programm ist allerdings nur vorhanden, wenn die lokale Version Office 2013 Professional Plus installiert wurde. Dieses...

  • Den viertgrößten Wert einer Matrix ermitteln

    207053   Die Funktion 'Kgrösste(Matrix,n)' ermittelt den Wert, der den Rang n innerhalb der angegebenen Matrix vertritt. Folgendes Beispiel ermittelt den 4-größten Wert innerhalb der Matrix. Das...

  • Alle Excel Startparameter

    500003 Excel hat verschiedene Startparamter. Nachfolgende Liste zeigt alle Startparamter auf und gibt eine kleine Erläuterung dazu. Erstellen Sie zuerst eine Verknüpfung zu Excel z. B. auf dem...

   

Excel-Inside auf Facebook Excel-Live News blog Excel-Inside RSS-Feed Twitter Account für Excel-Inside Mail an Excel-Inside 

Programmierung
Excel Auftragsprogrammierung Access Auftragsprogrammierung
Word Auftragsprogrammierung Outlook Auftragsprogrammierung
   
Unsere Produkte
Office Schulungen VBA, Excel, Access
E-Book Formeln und Funktionen Excel 2013