Projektanfrage

Projektanfrage über Web Formular   per Online-Formular 
Projektanfrage über E-Mail  Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!
Projektanfrage per Telefon  +49 (0)151 / 164 55 914
Projektanfrage weitere Informationen  weitere Informationen 

Sie benötigen Hilfe oder Unterstützung? Nutzen Sie für Ihre Anfrage unser Online-Formular, senden Sie uns eine Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!  oder rufen Sie uns einfach an.

Referenzen

 Bosch 
  T-Systems
  Hagebau
  Siemens
 Areva  VW
 Haufe-Lexware  British American Tobacco
  nagel group farbe

SVERWEIS versus INDEX / VERGLEICH

In diesem Beitrag vergleichen wir die beiden Möglichkeiten Daten in einer Liste zu suchen und das Ergebnis auszugeben.

Der von Excel vorgesehene Befehl lautet SVERWEIS(). Die allgemeine Syntax lautet: =SVERWEIS(Suchkriterium; Suchmatrix; Ergebnisspalte; [exakter Treffer])

Dei Funktion SVERWEIS hat aber einen kleinen Nachteil: Die Suche funktioniert nur nach rechts, ausgehend von der Suchspalte. Ergebnisse, welche links von der Suchspalte liegen können nicht ermittelt werden.

Um Daten links ausgehend von der Suchspalte auszulesen muss folgende Funktion verwendet werden: =INDEX(Matrix; VERGLEICH(Suchkriterium; Matrix).

Folgende Daten liegen dem Beispiel zu Grunde:

 

Nachfolgend sehen Sie verschiedene Verianten, um die Artikelbezeichnung bzw. den Lagerort für eine beliebige Artikelnumer zu suchen.

 

Beispiel 1 verwendet den Befehl SVERWEIS():

Erfassen Sie dazu folgende Formel: =SVERWEIS(E6;$B$5:$C$20;2;0)

Der Suchbegriff, also die Artikelnummer befindet sich in Zelle E6.

 

Beispiel 2 liest die Artikelbezeichnung mit Hilfe der kombinierten Funktionen INDEX/VERGLEICH aus:

Folgende Funktion ist dazu notwendig, wenn der Suchbegriff (Artikelnummer) in der Zelle E12 steht :
=INDEX(C5:C20;VERGLEICH(E12;B5:B20;0))

 

Beispiel 3 liest ebenfalls mit Hilfe von INDEX/VERGLEICH den Lagerort aus, also die Spalte links neben den Suchbegriff. Diese Art des Auslesens lässt sich mit SVERWEIS so nicht umsetzen.

Verwenden Sie dazu folgende Formel: =INDEX(A5:A20;VERGLEICH(E18;B5:B20;0)). Der Suchbegriff befindet sich in Zelle E18.

 

Das Ergebnis sehen Sie in der folgenden Abbildung.

 

 

Anmerkung:

Wenn Sie Informationen rechts von der Suchspalte auslesen möchten, ist es eigentlich gleichgültig, welche Varianten Sie verwenden. Es gibt keinerlei Geschwindigkeitsunterschiede. Ich verwende gewohnheitsmäßig den SVERWEIS-Befehl, wenn ich Daten rechts der Suchspalte auslesen möchte und greife auf INDEX/VERGLEICH nur dann zurück, wenn links der Suchspalte ausgelesen werden soll.

Es bleibt damit Ihnen überlassen, für welche Variante Sie sich entscheiden.

Die Beispielmappe können Sie über den untenstehenden Downloadlink herunterladen.

Drucken

Projektanfrage

 Sie benötigen eine Auftragsprogrammierung?
 Oder suchen Unterstützung bei der 
 Lösungsfindung?

  Nutzen Sie unser Anfrageformular

  Jetzt anrufen unter 0151 / 164 55 914

 Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! Projektanfrage per Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! senden

  Weitere Informationen

sitepanel question2

P
R
O
J
E
K
T
A
N
F
R
A
G
E
Cookies erleichtern die Bereitstellung unserer Dienste. Mit der Bestätigung erklären Sie sich mit der Verwendung von Cookies auf Excel-Inside Solutions einverstanden.
Weitere Informationen Ok