Projektanfrage

Projektanfrage über Web Formular   per Online-Formular 
Projektanfrage über E-Mail  Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!
Projektanfrage per Telefon  +49 (0)151 / 164 55 914
Projektanfrage weitere Informationen  weitere Informationen 

Sie benötigen Hilfe oder Unter-stützung? Nutzen Sie für Ihre Anfrage unser Online-Formular, senden Sie uns eine Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! oder rufen Sie uns einfach an.

   
      Referenzen 

 Bosch 
  T-Systems
  Hagebau
  Siemens
 Areva  VW
 Haufe-Lexware  British American Tobacco
  nagel group farbe
   
     Programmierung
Excel Auftragsprogrammierung Access Auftragsprogrammierung
Word Auftragsprogrammierung Outlook Auftragsprogrammierung
   
   

Projektanfrage

 Sie benötigen eine Auftragsprogrammierung?
 Oder suchen Unterstützung bei der Lösungs-
 findung?

  Nutzen Sie unser Auftragsformular

  Jetzt anrufen unter 0151 / 164 55 914

 Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! Projektanfrage per Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! senden

  Weitere Informationen

sitepanel question2

P
r
o
j
e
k
t
a
n
f
r
a
g
e
   

SVERWEIS versus INDEX / VERGLEICH

In diesem Beitrag vergleichen wir die beiden Möglichkeiten Daten in einer Liste zu suchen und das Ergebnis auszugeben.

 

Der von Excel vorgesehene Befehl lautet SVERWEIS(). Die allgemeine Syntax lautet: =SVERWEIS(Suchkriterium; Suchmatrix; Ergebnisspalte; [exakter Treffer])


Dei Funktion SVERWEIS hat aber einen kleinen Nachteil: Die Suche funktioniert nur nach rechts, ausgehend von der Suchspalte. Ergebnisse, welche links von der Suchspalte liegen können nicht ermittelt werden.

 

Um Daten links ausgehend von der Suchspalte auszulesen muss folgende Funktion verwendet werden: =INDEX(Matrix; VERGLEICH(Suchkriterium; Matrix).


Folgende Daten liegen dem Beispiel zu Grunde:



Nachfolgend sehen Sie verschiedene Verianten, um die Artikelbezeichnung bzw. den Lagerort für eine beliebige Artikelnumer zu suchen.


Beispiel 1 verwendet den Befehl SVERWEIS():

Erfassen Sie dazu folgende Formel: =SVERWEIS(E6;$B$5:$C$20;2;0)

Der Suchbegriff, also die Artikelnummer befindet sich in Zelle E6.

 

Beispiel 2 liest die Artikelbezeichnung mit Hilfe der kombinierten Funktionen INDEX/VERGLEICH aus:

Folgende Funktion ist dazu notwendig, wenn der Suchbegriff (Artikelnummer) in der Zelle E12 steht :
=INDEX(C5:C20;VERGLEICH(E12;B5:B20;0))


Beispiel 3 liest ebenfalls mit Hilfe von INDEX/VERGLEICH den Lagerort aus, also die Spalte links neben den Suchbegriff. Diese Art des Auslesens lässt sich mit SVERWEIS so nicht umsetzen.

Verwenden Sie dazu folgende Formel: =INDEX(A5:A20;VERGLEICH(E18;B5:B20;0)). Der Suchbegriff befindet sich in Zelle E18.


Das Ergebnis sehen Sie in der folgenden Abbildung.


 

Anmerkung:

Wenn Sie Informationen rechts von der Suchspalte auslesen möchten, ist es eigentlich gleichgültig, welche Varianten Sie verwenden. Es gibt keinerlei Geschwindigkeitsunterschiede. Ich verwende gewohnheitsmäßig den SVERWEIS-Befehl, wenn ich Daten rechts der Suchspalte auslesen möchte und greife auf INDEX/VERGLEICH nur dann zurück, wenn links der Suchspalte ausgelesen werden soll.

Es bleibt damit Ihnen überlassen, für welche Variante Sie sich entscheiden.

Die Beispielmappe können Sie über den untenstehenden Downloadlink herunterladen.


   

Relevante Artikel

  • Benutzernamen (User-Name) per Formel auslesen

    In diesem Beispiel zeigen wir Ihnen, wie sich der Benutzername, also der Name aus der Windows-Anmeldung über eine Formel ausgelesen werden kann. Eine VBA-Lösung haben wir bereits in einem separaten Artikel...

  • Dynamische Bilderanzeige

    In diesem Beitrag zeigen wir Ihnen, wie in einer Zelle verschiedene Bilder nach Eingabe einer Bildnummer angezeigt werden können. Als Ausgangsbasis dient eine Sammlung von 4 Bildern, im Beispiel von...

  • Laufende Nummerierung trotz Autofilter

    Sie haben eine Liste mit fortlaufender Nummerierung. Wenn Sie in dieser Liste nun den Autofilter verwenden, wird standardmäßig die laufende Nummer unterbrochen, indem die gefilterten  Zeilen...

  • Werte ohne die Zahl 3 addieren

    207052   Es soll eine Zahlenkolone von A1 bis A10 summiert werden. Jedoch soll in dieser Summe der Wert 3 unberücksichtigt bleiben.     A B C 1 10     2 9     3 8     4 7     5 6     6 5     7 4     8 3     9 2     10 1     11       12       13 Lösungen:...

  • Eingabe von Brüchen

    Bei der Erfassung von Werten in eine Excel-Zelle greift die automatische Zahleninterpretation und versucht die Zahlen in das gewünschte Format umzuwandeln. Das funktioniert in der Regel auch ganz...