Projektanfrage

Projektanfrage über Web Formular   per Online-Formular 
Projektanfrage über E-Mail  Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein!
Projektanfrage per Telefon  +49 (0)151 / 164 55 914
Projektanfrage weitere Informationen  weitere Informationen 

Sie benötigen Hilfe oder Unter-stützung? Nutzen Sie für Ihre Anfrage unser Online-Formular, senden Sie uns eine Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! oder rufen Sie uns einfach an.

   
      Referenzen 

 Bosch 
  T-Systems
  Hagebau
  Siemens
 Areva  VW
 Haufe-Lexware  British American Tobacco
  nagel group farbe
   
     Programmierung
Excel Auftragsprogrammierung Access Auftragsprogrammierung
Word Auftragsprogrammierung Outlook Auftragsprogrammierung
   
   

Projektanfrage

 Sie benötigen eine Auftragsprogrammierung?
 Oder suchen Unterstützung bei der Lösungs-
 findung?

  Nutzen Sie unser Auftragsformular

  Jetzt anrufen unter 0151 / 164 55 914

 Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! Projektanfrage per Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! senden

  Weitere Informationen

sitepanel question2

P
r
o
j
e
k
t
a
n
f
r
a
g
e
   

SVERWEIS versus INDEX / VERGLEICH

In diesem Beitrag vergleichen wir die beiden Möglichkeiten Daten in einer Liste zu suchen und das Ergebnis auszugeben.

 

Der von Excel vorgesehene Befehl lautet SVERWEIS(). Die allgemeine Syntax lautet: =SVERWEIS(Suchkriterium; Suchmatrix; Ergebnisspalte; [exakter Treffer])


Dei Funktion SVERWEIS hat aber einen kleinen Nachteil: Die Suche funktioniert nur nach rechts, ausgehend von der Suchspalte. Ergebnisse, welche links von der Suchspalte liegen können nicht ermittelt werden.

 

Um Daten links ausgehend von der Suchspalte auszulesen muss folgende Funktion verwendet werden: =INDEX(Matrix; VERGLEICH(Suchkriterium; Matrix).


Folgende Daten liegen dem Beispiel zu Grunde:



Nachfolgend sehen Sie verschiedene Verianten, um die Artikelbezeichnung bzw. den Lagerort für eine beliebige Artikelnumer zu suchen.


Beispiel 1 verwendet den Befehl SVERWEIS():

Erfassen Sie dazu folgende Formel: =SVERWEIS(E6;$B$5:$C$20;2;0)

Der Suchbegriff, also die Artikelnummer befindet sich in Zelle E6.

 

Beispiel 2 liest die Artikelbezeichnung mit Hilfe der kombinierten Funktionen INDEX/VERGLEICH aus:

Folgende Funktion ist dazu notwendig, wenn der Suchbegriff (Artikelnummer) in der Zelle E12 steht :
=INDEX(C5:C20;VERGLEICH(E12;B5:B20;0))


Beispiel 3 liest ebenfalls mit Hilfe von INDEX/VERGLEICH den Lagerort aus, also die Spalte links neben den Suchbegriff. Diese Art des Auslesens lässt sich mit SVERWEIS so nicht umsetzen.

Verwenden Sie dazu folgende Formel: =INDEX(A5:A20;VERGLEICH(E18;B5:B20;0)). Der Suchbegriff befindet sich in Zelle E18.


Das Ergebnis sehen Sie in der folgenden Abbildung.


 

Anmerkung:

Wenn Sie Informationen rechts von der Suchspalte auslesen möchten, ist es eigentlich gleichgültig, welche Varianten Sie verwenden. Es gibt keinerlei Geschwindigkeitsunterschiede. Ich verwende gewohnheitsmäßig den SVERWEIS-Befehl, wenn ich Daten rechts der Suchspalte auslesen möchte und greife auf INDEX/VERGLEICH nur dann zurück, wenn links der Suchspalte ausgelesen werden soll.

Es bleibt damit Ihnen überlassen, für welche Variante Sie sich entscheiden.

Die Beispielmappe können Sie über den untenstehenden Downloadlink herunterladen.


   

Relevante Artikel

  • Anzahl der verschiedenen Werte einer Liste ermitteln

    207054 Mit der folgenden Formel kann die Anzahl der unterschiedlichen Werte innerhalb einer angegebenen Matrix ermittelt werden. Wenn dabei eine Zahl >0 erreicht wird, wird der Funktion Summe der Wert...

  • Verwendung der Gültigkeitsprüfung

    Die Gültigkeitsprüfung oder Datenüberprüfung ist ein Excel-Feature, durch das eine korrekte Daten-Eingabe in ein Arbeitsblatt sichergestellt wird. Es gibt verschiedene Möglichkeiten für die...

  • Unikate aus Liste extrahieren

    In diesem Beispiel liegt eine Liste vor, die einen Eintrag jeweils mehrfach enthält. Ziel ist nun, aus der Liste jeden der mehrfach vorkommenden Werte jeweils nur ein einziges mal auszulesen und in...

  • Laufende Nummerierung trotz Autofilter

    Sie haben eine Liste mit fortlaufender Nummerierung. Wenn Sie in dieser Liste nun den Autofilter verwenden, wird standardmäßig die laufende Nummer unterbrochen, indem die gefilterten  Zeilen...

  • Dateiname in Zellen einfügen

    207072 Um den Dateinamen inkl. Pfadangabe und Tabellenblatt in eine Zelle einzufügen kann folgende Funktion verwendet werden: =ZELLE("Dateiname";A1) Der Dateiname wird mit dieser Funktion allerdings in...