Berechnungen mit Fehlerwert #DIV/0!

Dieses Beispiel zeigt, wie Mittelwerte oder Summen trotz des Fehlerwerts #DIV/0! berechnet werden können.

Der Fehler #DIV/0! entsteht, wenn eine Zahl durch 0 dividiert wird. Das folgende Beispiel zeigt diesen Fehler in Zelle D9. Dort wird der Lagerbestand von 2.208 € durch 0 Stück dividiert, siehe Screenshot.

Aufgabenstellung Berechnung mit Fehlerwerten

Um nun den Mittelwert für den Zellbereich D4:D23 zu berechnen wird die Formel =MITTELWERT(D4:D23) verwendet. Da sich in diesem Zellbereich aber der Fehler #DIV/0! befindet liefert Excel als Ergebnis ebenfalls den Fehlerwert #DIV/0! zurück. Um dieses Problem zu umgehen, erfassen Sie in Zelle D25 folgende Formel: {=MITTELWERT(WENNFEHLER(D4:D23;""))}. Da es sich um eine Matrix-Funktion handelt, dürfen die geschweiften Klammern nicht manuell eingetragen werden. Diese werden mit Hilfe der Tastenkombination [Strg] + [Umschalt] + [Enter] erzeugt.

Berechnungsergebnis Summierung mit Fehlerwerten

Mit Hilfe der Funktion WENNFEHLER() wird der Fehlerwert #DIV/0! von der Berechnung ausgeschlossen, so dass nur noch die korrekten Werte in die Mittelwertberechnung einfließen. Möchten Sie anstatt des Mittelwerts die Summe berechnen, dann zeigt sich das gleiche Bild. Auch die Berechnung der Summe kann mit der Matrixfunktion durchgeführt werden. Die korrekte Formel lautet {=SUMME(WENNFEHLER(D4:D23;""))}. Auch hier handelt es sich wieder um eine Matrixfunktion welche mit der Tastenkombination [Strg] + [Umschalt] + [Enter]  abgeschlossen werden muss, um die geschweiften Klammern hinzuzufügen.

Diese Logik funktioniert bei allen Fehlerwerten. Befindet sich beispielsweise anstatt des Fehlerwertes #DIV/0! der Fehlerwert #NV oder ein anderer Fehlerwert in dem zu berechnenden Zellbereich, so werden diese ebenfalls mit der Ergänzung um die Formel WENNFEHLER() und der Deklaration als Matrix-Funktion von der Berechnung ausgeschlossen.

Möchten Sie zuerst ermitteln, wie viele Fehlerwerte vorliegen, dann hilft der Tipp  Fehlerwerte zählen weiter.

Drucken