Einfügen von Leerzeilen in eine fortlaufende Excel-Liste

In diesem Beispiel zeigen wir eine Möglichkeit, um formelbasiert Leerzeilen in eine fortlaufende Excel-List ein zufügen.
Dabei spielt es keine Rolle ob die Liste Zahlen oder Texte enthält.

Die folgende Abbildung zeigt die Ausgangstabelle mit einer Reihe von Bestellnummern.



Ziel ist es, in Spalte B eine Liste mit jeweils einer Leerzeile zwischen den einzelnen Bestellnummern zu erzeugen. 
Erfassen Sie dazu folgende Formeln in Zelle B5 und kopieren Sie diese nach unten: =WENN(REST(ZEILE($A5)-1;2)=0;INDEX($A$5:$A$30;(ZEILE(A5)-2)/2);"")

Sollen statt einer Leerzeile 2 Leerzeilen hinzugefügt werden, dann erfassen Sie in Zelle C5 diese Formel und kopieren diese ebenfalls so weit wie nötig nach unten: =WENN(REST(ZEILE($A5)-2;3)=0;INDEX($A$5:$A$30;(ZEILE(A5)-2)/3);"")

Diese Formeln weichen nur in ein paar Punkten voneinander ab. Dies können Sie ganz einfach sehen, wenn Sie diese beiden Formeln vergleichen.

1 Leerzeile  :  =WENN(REST(ZEILE($A5)-1;2)=0;INDEX($A$5:$A$30;(ZEILE(A5)-2)/2);"")
2 Leerzeilen: 
 =WENN(REST(ZEILE($A5)-2;3)=0;INDEX($A$5:$A$30;(ZEILE(A5)-2)/3);"")

Durch die Anpassung der rot markierten Werte, können ganz einfach auch 3, 4 oder mehrere Zeilen eingefügt werden.


Das folgende Beispiel zeigt, wie sich Blöcke von 2 bzw. 3 Zeilen bilden lassen.
Erfassen Sie dazu in Zelle D5 folgende Formel: =WENN(REST(ZEILE($A1);3)<>0;INDEX($A$5:$A$30;ZEILE()-4-GANZZAHL((ZEILE(A1)-0)/3));"")
Diese Formel sorgt dafür, dass immer zwei Werte als Block angezeigt werden und danach jeweils eine Leerzeile eingefügt wird.

Auch hier noch der Vollständigkeit halber die Formel, um Blöcke mit 3 Werte zu erzeugen: =WENN(REST(ZEILE($A1);4)<>0;INDEX($A$5:$A$30;ZEILE()-4-GANZZAHL((ZEILE(A1)-0)/4));"")

Das Ergebnis der vier Formeln sehen Sie in der folgenden Abbildung.





Drucken