Fehlerwerte zählen

Sie haben eine etwas umfangreichere Kalkulation erstellen und möchten prüfen, ob sich noch irgendwo Fehlerwerte befinden. Dieses Beispiel zeigt, wie sich auf einem Tabellenblatt alle vorhandenen Fehler zählen lassen.

In den Zellen B3:B11 befinden sich die Zellen, welche überprüft werden sollen, siehe Screenshot.



Ziel is es nun, zu ermitteln, wie viele Fehler insgesamt in dem Zellbereich vorhanden sind. Erfassen Sie dazu in Zelle B14 folgende Formel: {=SUMME(ISTFEHLER(B3:B11)*1)}. Da es sich bei dieser Formel um eine Matrix-Formel handelt, muss diese mit der Tastenkombination [Strg] + [Umschalt] + [Enter] abgeschlossen werden. Das ergebnis lautet in diesem Fall 4.

Um zu ermitteln wie häufig der Bezugsfehler #BEZUG! in dem Zellbereich vorhanden ist, erfassen Sie diese Formel in Zelle B16=ZÄHLENWENN(B3:B11;#BEZUG!)
Das Ergebnis lautet 2, siehe Abbildung.

Drucken