Zellen-Adresse für Werte aus einer Matrix ermitteln

Dieses Beispiel zeigt, wie sich die Zellen-Adresse für das Ergebnis eines Verweises beziehungsweise für das Ergebnis einer Berechnung ermitteln lässt.

Als Ausgangspunkt dient eine kleine Matrix mit verschiedenen Werten, siehe Abbildung1.


Abb. 1

Im ersten Schritt wird nun die kleineste und die größte Zahl ermittelt. Dazu verwenden wir in Zelle H4 zur Ermittlung des kleinsten Weret folgende Formel: =MIN(B2:E5) und in Zelle H5 zur Ermittlung des größten Wertes die Formel =MAX(B2:E5). Das Ergebnis sehen Sie in Abbildung 2.


Abb. 2

Wie Sie sehen, wurde die Zahl 2 als kleinster und die Zahl 17 als größter Wert ermittelt. 

Soweit so gut. Ziel ist es nun, die Zellen-Adresse der beiden Werte zu ermitteln. Der Wert 2 befindet sich in Zelle C3 und der Wert 17 in Zelle E4.

Mit Hilfe von Excel sollen diese Zelladressen nun automatisch ermittelt werden. Tragen Sie dazu folgende Formel in Zelle I4, um die Zelladresse für den kleinsten Wert aus Zelle H4 zu ermitteln ein:
=ADRESSE(INDEX(ZEILE(B2:B5); SUMMENPRODUKT((B2:E5=H4)*(ZEILE(B2:E5)-1)));INDEX(SPALTE(B2:E2); SUMMENPRODUKT((B2:E5=H4) *(SPALTE(B2:E5)-1)));1;1)

Zur Ermittlung der Zelladresse für den größten Wert erfassen Sie folgende Formel in Zelle I5:
=ADRESSE(INDEX(ZEILE(B2:B5); SUMMENPRODUKT((B2:E5=H5)*(ZEILE(B2:E5)-1)));INDEX(SPALTE(B2:E2); SUMMENPRODUKT((B2:E5=H5) *(SPALTE(B2:E5)-1)));1;1);1;1)

Das Ergebnis sehen Sie in Abbildung 3.


Abb. 3

Es spielt keine  Rolle, wie der Wert in Spalte H ermittelt wurde. In diesem Beispiel wurden die Min- und Max-Funktion verwendet. Sie können jedoch jede andere beliebige Funktion wie SVERWEIS() etc. anwenden. Alternativ können Sie die Werte auch manuell eintragen. Die Formel liest aus der Matrix die entsprechenden Werte aus.

Die Beispieldatei können Sie über den folgenen Link herunterladen.
Zellen-Adresse aus Matrix auslesen


Ergänzung:

Befinden sich in der Matrix allerdings doppelte Werte, dann funktionioniert die oben dargestellte Lösungsvariante nicht. Im folgenden Beispiel zeigen wir Ihnen eine Möglichkeit, um Zell-Adressen aus einer Matrix mit doppelten Werten auszulesen.



Der Ansatz in diesem Beispiel verfolg eine Lösung mit der Formel ZÄHLENWENN() anstatt mit der Funktion SUMMENPRODUKT() wie aus Beispiel 1.

Gibt es nur einen identischen Wert in der Matrix, dann wird die Zelladresse mit der folgenden Formel ermittel:
=WENN(ZÄHLENWENN($B$5:$F$8;H6)=1; ADRESSE(MAX(INDEX(ZEILE(B$5:F$8)*(B$5:F$8=H6);));MAX(INDEX(SPALTE(B$5:F$8)*(B$5:F$8=H6);)));"")

Die folgende Formel ermittelt je Suchwert die Zelladresse, die am weitesten unten und darin am weitesten rechts liegt. Tragen Sie diese dazu in Zelle J6 ein.
=WENN(ZÄHLENWENN($B$5:$F$8;H6)>1; ADRESSE(MAX(INDEX(ZEILE(B$5:F$8)*(B$5:F$8=H6);));MAX(INDEX(SPALTE(B5:F5)*(B$5:F$8=H6)*(MAX(INDEX(ZEILE(B$5:F$8)*(B$5:F$8=H6); ))=ZEILE(B$5:F$8));)));"")

Um die Zelladresse zu ermitteln, welche am weitesten oben und darin am weitesten links liegt, verwenden Sie bitte folgende Formel in Zelle K6.
=WENN(ZÄHLENWENN(B$5:F$8;H6)<2;""; ADRESSE((ZEILE(F$8)+ZEILE($B$5)-1-MAX(INDEX((ZEILE(F$8)+ ZEILE($B$5)-1-ZEILE(B$5:F$8))*(B$5:F$8=H6);))); SPALTE(F$8)+SPALTE($B$5)-1-MAX(INDEX((SPALTE(F$8)+ SPALTE($B$5)-1-SPALTE(B$5:F$8))* (B$5:F$8=H6)*(ZEILE(F$8)+ ZEILE($B$5)-1- MAX(INDEX((ZEILE(F$8)+ ZEILE($B$5)-1 -ZEILE(B$5:F$8))*(B$5:F$8=H6) ;))=ZEILE(B$5:F$8)) ;))))

Diese beiden Formeln wurden so konstruiert, dass Zeilen/Spalten innerhalb des Auswertungsbereiches B5:F5 und vor Zeile 4  und Spalte B eingefügt werden können. Es wird auch nur eine Adresse ausgeben, wenn der Suchwert doch nur einmal vorhanden ist.

An dieser Stelle bedanken wir uns herzlich für den von neopa erstellten Lösungsvorschlag.

Die Beispieldatei können Sie unter folgendem Link herunterladen.
Zell-Adresse aus Matrix auslesen - Beispiel 2

Drucken