SUMMEWENN mit Textfragmenten

Mit Hilfe der Funktion SUMMEWENN() werden in einem Bereich nur die Werte summiert, die mit dem Suchkriterium übereinstimmen.

Mit =SUMMEWENN(A1:A50;">20";B1:B50") wird im Bereich A1:A50 geprüft, ob der Wert größer 20 ist. Bei einem Treffer, also wenn das Suchkriterium passt, werden die Beträge im Bereich B1:B50 entsprechend addiert.

Genauso funktioniert es, wenn man in Spalte A nach einem Text sucht. Im folgenden Beispiel sollen beispielsweise alle Umsätze der Firma "Müller GmbH & Co. KG" addiert werden. Die Firmennamen stehen entsprechend in Spalte A und die Umsätze in Spalte B, siehe Abbildung 1.


Abbildung 1

Um nun die Umsatzerlöse mit der Firma "Müller GmbH & Co. KG" zu ermitteln verwenden Sie einfach folgende Formel: =SUMMEWENN(A3:A12;"Müller GmbH & Co. KG";B3:B13). Das Ergebnis lautet 16.943,80 €.

Wenn Sie genau hinsehen, finden Sie in Zelle A12 den Eintrag "Müller GmbH & Co.", es fehlt hier also der Zusatz "KG". Ziel soll es jedoch sein, sämtliche Umsätze der Firma Müller zu addieren

Verwenden Sie dazu folgende leicht modifizierte Formel: =SUMMEWENN(A3:A12;"Müller GmbH*";B3:B13)

Durch Verwendung des Jokers "*" werden nun alle Umsätze addiert, deren Textbezeichnung in Spalte A mit "Müller GmbH" beginnen. Damit können Textfragmente als Suchkriterium verwendet werden.

Durch die Verwendung des Jokers kann die Funktion SUMMEWENN, SUMMENWENNS, ZÄHLENWENN, ZÄHLENWENNS u. a. noch variabler eingesetzt werden.