Monats- bzw. Jahreswerte um den Wert 1 erhöhen

201001



Die Funktion Datum () + X Monate liefert ausgehend von einem Monatsletzten falsche Ergebnisse, da sich ein Bug in Excel befindet. Die Rechnung Datum() + 30 ergibt ebenfalls das falsche Ergebnis, da die Monate eine unterschiedliche Anzahl von Tagen haben.

 

Die Funktion =DATUM(JAHR(A1);MONAT(A1)+2;TAG(A1))

führt zu folgendem Ergebnis (Spalte C) 

A

B

C D
3 Datum  + Anzahl Mte. Ergebnis Richtig
4 31.12.2000 2 03.03.2001 28.02.2001
5 28.02.2001 2 28.04.2001 30.04.2001


Die folgende Lösung behebt den Fehler, der durch ungleich lange Monate im Monatsendbereich entsteht
.
 

Lösung

das Datum steht in A1

die zu addierenden Jahre in A2

die zu addierenden Monate in A3


in B1 (B ist Hilfsspalte) steht
=DATUM(JAHR(A1)+A2;MONAT(A1)+A3;TAG(A1))


in B2 steht

=WENN(UND(MONAT(A1+1)>MONAT(A1);MONAT(B1+1)=MONAT(B1));1;0)


das Enddatum in C1 lautet dann:

=DATUM(JAHR(A1)+A2;MONAT(A1)+B2+A3;WENN(B2=1;0;TAG(A1)-WENN(TAG(A1)>TAG(B1);TAG(B1);0)))

Wer sich die Hilfsspalte sparen will, schreibt halt alles in einer Formel in C1:

=DATUM(JAHR(A1)+A2;MONAT(A1)+WENN(UND(MONAT(A1+1)>MONAT(A1);MONAT(B1+1)=MONAT(B1));1;0)
+A3;WENN(WENN(UND(MONAT(A1+1)>MONAT(A1);MONAT(B1+1)=MONAT(B1));1;0)=1;0;TAG(A1)-WENN(TAG(A1)>TAG(DATUM(JAHR(A1)+A2;MONAT(A1)+A3;TAG(A1)));TAG(DATUM(JAHR(A1)+A2;MONAT(A1)
+A3;TAG(A1)));0)))