Verwendung der Gültigkeitsprüfung

Die Gültigkeitsprüfung oder Datenüberprüfung ist ein Excel-Feature, durch das eine korrekte Daten-Eingabe in ein Arbeitsblatt sichergestellt wird.

Es gibt verschiedene Möglichkeiten für die Einstellung der Gültigkeit einer Eingabe in eine Zelle, siehe Abbildung.

 

 

1. Jeden Wert:
In die Zelle kann jeder beliebige Wert erfasst werden
2. Ganze Zahl:
Hier können Sie die Unter- und Obergrenze der Ganzzahl definieren. Dezimalzahlen sind hier nicht zulässig
3. Dezimal:
Ähnlich wie Ganze Zahl, nur dass hier Dezimalzahlen erfasst werden müssen
4. Liste:
Bei Liste können Sie Gültigkeitslisten definieren. Sie erhalten nun ein Drop-Down-Feld, in dem Sie die Werte der Liste auswählen können
5. Datum:
Bei Datum können Sie ein Anfangs- und ein Enddatum bestimmen. Anschließend kann in der Zelle nur noch ein Datum zwischen diesen beiden Terminen erfasst werden.
6. Zeit:
Wie bei Datum können Sie hier eine Anfangs- und eine Endzeit erfassen.
7. Textlänge
Bei Auswahl der Option Textlänge können Sie bestimmen wie lang der zu erfassende Text sein soll bzw. höchstens sein darf.
8. Benutzerdefiniert:
Bei Benutzerdefiniert können Sie über eine Formel die Abfrage bestimmen

 

Auf die Punkte "4. Liste" und "8. Benutzerdefiniert" möchte ich etwas näher eingehen. Die anderen Optionen sind weitgehend selbsterklärend.


Erläuterungen zu Punkt 4. Liste:

Sie können eine Liste mit Gültigkeitskriterien auf dem gleichen Tabellenblatt erstellen und als Bereichsangabe übergeben. Es ist aber nicht ohne weiteres Möglich, eine Liste durch Selektion auf einem anderen Tabellenblatt auszuwählen. Möchten Sie jedoch eine Quell-Liste auf einem anderen Tabellenblatt oder gar einer anderen Arbeitsmappe erstellen so müssen Sie für diese Liste einfach nur einen Bereichsnamen vergeben.

Als Quell-Liste erfassen Sie nun ganz einfach diesen Namen. Haben Sie beispielsweise der Liste den Namen 'liste' gegeben, so erfassen Sie als Quelle einfach den Namen wie folgt: =liste

Jetzt verwendet Excel als Gültigkeitsliste die Quelle mit dem Namen liste und es ist vollkommen gleichgültig wo diese Liste steht, ob auf dem gleichen oder auf einem anderen Tabellenblatt. Ja es ist jetzt sogar egal, ob diese Liste gar in einer anderen Arbeitsmappe befindet. Steht die Quell-Liste jedoch in einer anderen Arbeitsmappe, so muss diese geöffnet sein, wenn die Gültigkeitsprüfung vorgenommen wird.



Erläuterungen zu Punkt 8. Benutzerdefiniert:

Über diesen Parameter können beliebige Formeln in der Datenüberprüfung verwendet werden. Beispielsweise lassen sich über die benutezerdefinierte Gültigkeitesprüfung Doppelerfassungen verhindern.

Gehen Sie dazu wie folgt vor:

  1. Starten Sie die Datenüberprüfung über das Menü Daten / Datentools / Datenüberprüfung --> Benutzerdefiniert
  2. Möchten Sie beispielsweise den Zellbereich A1:A100 Doppelerfassungen prüfen, dann geben Sie als Formel folgendes:  =ZÄHLENWENN(A:A;A1)=1
  3. Anschließend übertragen Sie die Gültigkeitskriterien durch Format-Übertrag auf die gewünschten Zellen in der Spalte A, z. B. A1 bis A100.
  4. Bei jeder Doppelerfassung im ausgewählten Bereich, hier Zelle A1 bis A100 wird nun ein Hinweis ausgegeben. Über die indiduelle Steuerung der Fehlermeldung können Sie auch einen individuellen Text hinterlegen.