Fortlaufende Reihen-Sequenzen ermitteln

In diesem Beispiel zeigen wir Ihnen, wie sich eine sequenzielle Reihe erzeugen lässt.

Als Ausgangliste dient eine Reihe mit verschiedenen Zahlen ab Zelle B4, wie Sie in der folgenden Abbildung sehen:

Ziel soll es nun sein, dass in Spalte C ab Zelle C4 eine sequenzielle Reihenfolge eingetragen wird. Der Wert 5 in Zelle B4 soll dabei die Nummer 1 bekommen, ebenfalls die Werte 5 in den Zelle B5 und B6. Der nächste Wert in Zelle B7 (35) soll die Nummer 2 bekommen, die Ziffer 3 in Zelle 8 die Nummer 4 usw. Wenn gleiche Ziffern weiter unten auftreten, dann soll dafür die gleiche sequenzielle Reihennummer eingetragen werden.

Erfassen Sie dazu in Zelle C4 folgende Formel:

=WENNFEHLER(SVERWEIS(B4;$B$3:C3;2;0);SUMME(MAX($C$3:C3);1))

Mit Hilfe der SVERWEIS-Funktion wird geprüft, ob in Spalte C bereits eine sequenzielle Nummer vorhanden ist. Falls ja, dann wird diese verwendet. Gibt es in Spalte C für eine Ziffer noch keine Nummer, dann wird mit Hilfe der SUMMEN-Funktion in Verbindung mit der Funktion MAX() eine neue sequenzielle Nummer erzeugt.

Das Ergebnis sehen Sie in der folgenden Abbildung.

 Nachfolgend können Sie die Formel live testen oder sich die Beispieldatei direkt herunterladen.